Stellar P3

Hi All, Owner of a Stellar P3 in Australia.
Just recently I have noticed that when I set my Stellar P3 into Idle mode, the downstream components connected to the P3 still receive power. This was never the case and the power to the downstream components were usually cut.

This seems to be an issue and the manual confirms that the downstream items connected to the P3 should be disconnected from power when the P3 is set to Idle.

Does anyone have any experience with this issue or how this could be fixed? @jamesh - hi James, would appreciate any insight you may have on the issue.


Welcome to the forum @arv!

I am certain that @jamesh will be able to help you with this issue.

1 Like

My Stellar P3, from new, didn’t disconnect power. The main board was changed under warranty (not a particularly easy job). Quite a few forum users had this issue.

I have heard a few people have this problem. I do believe a new board is needed in order for it to work properly. I’m not aware what is causing the issue but it seems like it’d be something very simple like a sticky relay. Are you using the remote or the front button? I’m guessing it doesn’t really matter.

If directed at me James, I was using the front button. I don’t use the remote. I do use some black insulating tape to cover the bright lights on the front panel ):-

Thanks for all the replies; much appreciated. :smiley:

I have been directed by PS Audio support to contact the Australian distributor, so will start that process now.

@jamesh - I have always used the remote to place the unit to Idle; however, since the fault developed, I had tried using the remote and the front button and it still doesn’t work.


Thanks for working with the distro, they’ll be able to get you going.

OK, good to know. I assumed the behavior would be the same but I wanted to double check.