Stellar Power plant 3 issue

Hi fellow listeners!
Sorry if this topic is a repeater, and sorry for my bad english.
I recently aquired a Stellar Power Plant 3 and was ready to set it up this morning. I switched it on after reading the instructions and plugging the units in at the back. I noticed my PS junior DAC had lost its network connection, so I reached for the power switch on the back. Since I put the new P3 on top of the DAC, I happened to switch that off instead. I know that you are not supposed to switch it off if the P3 isn’t in rest mode, but that happened now. After that incident I can’t switch it back on. There are no blinking diods and no hizzing from the inside like I heard the first time. I am about to replace the fuse, and I still wonder what the reset button does.
Any tips? Do I have to bring it to a retailer and have it fixed, or what should I do?

you might try the reset. Or after setting the power switch to “off”, unplugging the P3 for a few minutes., then plugging it back in. Flip the switch to “on”, and see if that works.

Thank you for replying! I replaced the fuse with a new one, not gold plated though… and it turned out to work fine! Problem solved!
Over and out

1 Like

Very good to hear.

Have you checked the front panel logo button? Often, when we switch the main power switch off, we forget that the front panel logo button needs to then be pressed.

Yes, I tried both that and the one on the remote.
If you are curious, the units connected to my P3 at the time was a pair of Avantgarde Duo Omega horn speakers, Junior DAC and a Tube amplifier called ”PrimaLuna Prologue Two”. They were all up and running.