Strata problem


I had an issue with my Strata couple weeks ago, the PS audio power button was flashing blue and no buttons was working, music was still playing but I was not able to do anything. I had to close it by the back power switch. When I power it back the same things happen 2 days after and again for a third time.

I tried to reset bridge and it work fine for 3-4 weeks and same thing just happen.

I’m trying right now to do a factory reset to see what it will do.

Anyone had the same problem?

Thank you!

Yes, mine did it a couple of times over the last couple of months. Each time it was after leaving it running for a few hours. Power cycled it each time and everything was fine. It has not done it the last few weeks, including playing it all day yesterday and today.

I’ve had one playing on and off at the house for a few months now. This happened probably twice the first week I had it. Power cycle with the rear switch always fixed it. Hasn’t happened since.

Finally it didn’t get better, it freeze during the factory reset at « please wait » I let it go for 4 hours without success.

Power on/off and tried factory reset again, same thing freeze up.

Now it is worst I can’t even play more than 1 songs without having the ps audio button flashing.

There is a female voice saying to configure it with the app but the app doesn’t work and MUZO has no option to configure and make it freeze.

Any idea what I can try at that point?

The PS Connect app is now live on the app store, try giving that a shot.

Glad the app is back, I just installed it. I dont see any setting I to do though.

Anyway try to play a song vis Tidal and at the second I started it, Ps audio is flashing blue :frowning:

Is it the version for the iPad? If it is, it still isn’t installing.
Nevermind. I was trying to use the version that was connected to the QR code.
I have it now, thanks.

@Tonic OK, I’m not familiar with any kind of configuring needed. Give our service guys a buzz and they may know what’s going on here.

@todd-r You’ll need to go to the app store and install a new version of it. Great, looks like this is exactly what you just did. Thanks!