TIDAL's RIhanna MQA songs do not get decoded correctly by Directstream Junior

Hello,

I have a problem at listening to some MQA titles in tidal. I have a DSJ with snowmass and I am streaming from TIDAL using the Mconnect app on an android phone. There are some MQA songs that do not get decoded correctly. All RIhanna MQA songs are definitely troublesome others (from other artists) work fine. Has anybody else encountered this problem?

I have found this problem before with SOME other songs but forgot to report it at the time and do not remember which ones. The problem with Rihanna’s MQA songs is a repeatable issue.

Can you list the songs/albums

Any Rihanna’s Song in MQA in tidal I tried from original Rihanna’s albums. EX. disturbia, diamond for sure and a few other. Cannot try now. Other MQA songs from other bands work fine. It is not a subtle thing the song is completely distorted down to cranky noise where you can barely guess words.
If you cannot reproduce it I will record a few seconds of it and send it via attachment.

Renato

Yeah I just played through tidal on mcontrol and it is screwed up. I then played it on tidal through roon and it is fine. Weird. This was with a DS Senior but the major player the Bridge 2 is the same.

I also received an email from your colleague Joey as I sent also an email. Apologies for the duplicated effort from your side. Should I assume this is something psaudio will investigate further or is the determination this is a Tidal problem and I should contact them?



Using Roon Nucleus+ w/ DSD Sr. Waited a bit to take the pic of the DSD. Thanks, been a while since I worked that album. Unapologetic was fine too… OK, after a few min… I’m done… back to smooth jazz and Boney James…

That’s ok, I don’t work for PS Audio, I was just feeling helpful! Hope they can figure it out for you.

1 Like

I thought it was illegal to play Rihanna songs through the DSjr?? :slight_smile:

2 Likes

Not illegal to show that picture…smoke show for sure…

Well I am between a rock and a hard place now, Tidal says no problem, psaudio says not my problem

This is very strange. I haven’t tried it myself but I suppose we can on Monday. It sounds like the problem is only when Mconnect is controlling the Bridge? If you play the same thing on Roon it properly connects and plays right?

The way these things work is what’s confusing me. When you connect to the track on Tidal, either through McConnect or Roon the software is merely connecting the Bridge to a memory location on a server. McConnect and Roon will connect the Bridge to the exact same memory location where the track lives. The difference then is that Roon will be connected to the memory location on Tidal’s server and does the first bit of processing. In the case of McConnect the Bridge is directly tied to that server location without going first through Roon.

So, for whatever reason, it appears Roon is handling the track in a way the Bridge is not. I know that’s not helping fix the problem, but that’s how it works.

I’ll forward this thread to Mark in service so he can try the same thing, though chances are pretty good we won’t be able to fix it right away since a: we don’t control or manage McConnect (if that’s the problem) or b: the Bridge (if it’s the problem) takes some time to fix because it too is managed by outside programmers.

If I had to guess there’s something different with that track that doesn’t both Roon and it does bother the Bridge. It’s unlikely it’s McConnect since it is only connecting the Bridge to the server location to start streaming.

I do not have roon, Veneet has it and he says it works fine with Roon and indeed it does not work with Mconnect. This seems to be true both with Junior and senior.
Hope it helps.

Renato

And only on that song so far. Bizarre. I suspect the Bridge since, as I suggested, McConnect only pairs the memory location to the Bridge. Hopefully we can get to the bottom of it for you Monday.

No, all songs of that album, all Rihanna songs in MQA.
Renato

Hi Paul, did you give it to support? were they able to duplicate the problem?
Cheers,
Renato

Yes and it turns out we can duplicate it and tracked it down to that recording. It’s Tidal’s issue whether they choose to recognize it or not.

Hi,
Thank you for following up. As you did root cause analysis is there any info you have I can provide to TIDAL to help them. Identify the problem? Any idea while with Roon it works fine instead?

Thanks again.

Renato