Problem streaming from Tidal to DS DAC

Several songs on Tidal (but not all) come out as highly distorted when played through the DS Dac and the mconnect app. There is no connection between the type of file, as in MQA or not, and the tendency to distort. However, the same songs work perfectly fine when played on my iPad directly through the Tidal app.

Any ideas what the cause of this could be? And cure for it.

Have you restarted both the DS and your router? Separate switch? Reseat all Ethernet contact points (also the Bridge card) ? This is what I would do.

Now Tidal stopped working via mConnect and Bridge altogether. Songs won’t play. Spotify works just fine though. Bandwidth is fine. I’m paying for 250 MBit/s and am getting 180 via WiFi in the listening room. And since the DAC is connected via Ethernet it should be having even better bandwidth.

Have restarted the DAC several times but can’t switch of the network until other family members don’t need it.

Sorry to hear that. Can you reach out to our customer service people and get some assistance? We’d be glad to help.

Re-installed mConnect Control app. Apparently I wasn’t using the “control” version previously. Now I have internet radio (yay!) and a link to Spotify within the app (meh) but am now getting a funny error message when trying to play Tidal

Error shows regardless of type of file, MQA or regular quality.

Great, having the control app should work. Try rebooting your network and the DAC with the rear switch. This should help get the streaming going again.

While I was trouble shooting I upgraded the Bridge firmware. That didn’t fix the problem. I’ll reboot our network tonight when all family members are off it. I don’t really see why it should work though, when everything else running through mConnect works and it’s only Tidal that having problems.

And if rebooting doesn’t work, I’ll contact support like Paul suggested.

Enjoying some internet radio for now!

1 Like

I started having the same issue described above just this morning. As of yesterday, I was using the MConnect Control App to stream Tidal everyday. Then this morning, I started receiving the ‘Delay in streaming or unsupported file format’ consistently when trying to use Tidal.

Internet radio does work, so it doesn’t seem to be an actual network / data getting through to the DS issue. But I still tried restarting the modem, the DS, and the MConnect apps (one-by-one). I also tried changing my Tidal settings from Master down to Normal since the message did hint at the file format being an issue. All to no avail. Also, I never had the distortion issue mentioned in the first post; it just worked yesterday and does not work today.

It seems jaydz had this problem in July. It’s on another thread. He tried rebooting everything and it didn’t work.

I also found this thread, which seems to be essentially the same issue:

However, the solution provided there (making sure both the DS and MConnnect are using the same IP settings, whether DHCP or Static IP) did not work for me today.

One of my colleagues just tried with the MConnect app and Tidal and has the exact same issue. Too early to say for sure, but there may be something going on with Tidal.

It definitely feels like there is a disconnect between Tidal and MConnect lately. Until the last bugfix update of the app, the Tidal login token expired every 24 hours. That lasted for a few weeks if I recall correctly. I sure hope this one doesn’t take that long since it means losing the ability to play most anything from my system…sigh.

Rebooting did not work but then after going for a run all of a sudden it did. Running is a great problem solver!

Honestly, I suspect that Tidal made some sort of upgrade to their software without making sure that all apps running Tidal were compatible. This happened to me in a previous life when I was playing via a Naim streamer. All of a sudden Tidal stopped working. This caused a ruckus on the Naim forum as it affected all users of Naim streamers more than a few years old and within two days the problem was solved. The difference was that Naim had its own app and was in control of contacts with Tidal. The problem was therefore easier to fix for them than for PS Audio, which is still depending on a third party app.

I’m really looking forward to Octave! (For a number of reasons, I’ve never really taken to MConnect. It works - most of the time - but that’s it.

1 Like

Yep, no changes on my end but it is working again as of this morning. All in, only a 24hr inconvenience…and yet a day without music is a rough day!

Indeed! That’s why I still buy CD’s and LP’s. But streaming is convenient and I wouldn’t want to be without it.

1 Like

Good to know. I can’t stand running but if it solved this, maybe I should start. :grin:

I’m almost exclusively an Apple user and my phone and iPad have been receiving a few updates lately. I wonder if this had anything to do with it. Also, what you bring up, the number of apps that pipe Tidal through them. Keeping all of these working properly with constant updates is crazy.

1 Like