Upgraded Dac II to DSD not powering up


#1

I purchased a DAC II and DSD upgrade at the same time. PS Audio did the upgrade, the unit came and would not power up. I installed cables and power cord, hit the switch on the rear and pressed the logo button on the front left, nothing. I called PS Audio and spoke to Alex Paananen, he gave me an RA number and I returned the unit via fedex. After a couple of weeks I received the following email from Alex “My technician was not able to get to your unit early this week. He has had your unit on the bench today, with no problem reproduced. The unit turns on with no issues. Is there something we are missing here? The unit passed our final audio tests and is being packaged to leave with our FedEx collection today.”

What am I doing wrong? The unit returned today and still will not initialize, I am getting nothing no lights, not even a flicker? I have had several Dacs and never had a problem getting any of them to work. I do not want to waste more time sending the unit back, based on the above statement PS Audio had the unit running which makes me believe I am doing something wrong. Too much money invested for a unit that I cannot get to turn on.


#2

Welcome, mb1534.

This sounds completely bizarre. I would start with the very basic - is there power on the outlet, try another power cord, etc.


#3

Yep I did, I also tried it alone in another circuit with the power cord from PS Audio. I even tried the O instead of the - as the turn on option… I really don’t get it, I’m sitting here right now looking at Alex’s reply and am baffled…


#4

Does it need an SD card installed to operate?


#5

Transportation jarred something, perhaps like the fuses or something. so when you sent it back it ‘fixed’ the problem. (I hate when that happens) let us know what it does when you get it back. As long as you have power at the input, it’s not you. We’re here to help out. Keep us posted.

–SSW


#6

Weird. Did you try pressing the display button on the remote, in case it was somehow turned off?


#7

ditto on the display button on the remote. Also check if the unit gets warm after an hour or so.

There are instructions on the “support” area on how to remove the cover and check the 2 fuses and wire connections. [unplug power before opening].

If the unit gets warm perhaps the display is intermittent or has a loose wire.


#8

Yep just got home it is warm, unit not identified by apple, so something is amiss. It is not the display because I tried all those tests. I will check fuses…


#9

I know I am posting a lot, this is really driving me crazy. I have never had to repair a new piece of equipment in my 30 some years in this hobby. This really scares me with PS Audio products, I ordered the Dac, the PWT and the perfect wave power base. The PWT is backordered so that and the base have not arrived yet…

I took the top off the unit and set it on the side, with the ground wire still connected. I checked the fuses and reinstalled them, I checked all the wire connections. With out replacing the lid I plugged the unit in and it initialized right away. Happily I put the lid back on the unit, before reinstalling the screws I plugged the unit back in and flipped the switch, NOTHING!!! I removed the lid and placed it next to the unit with the ground still connected to the lid, powered the unit on and again it initialized no problem. I carefully reinstalled the lid and again tried to power the unit back up and nothing! Removed the lid unit powers right up. I am baffled. I watched the video and when Bill Abplanalp installed the kit there is no yellow ground to the lid.

Each time I reinstalled the lid I made sure I did not jiggle any wires, any ideas?


#10

Gee. I feel for you right now.pulling-hair_gif

This is indeed bizarre but what you have done and posted could be an important clue for the support team and engineers.

The cover might be touching or putting pressure on something? I would not be too worried about PSA quality or support as both are well considered to be excellent.

Meanwhile we/they need to get you running smoothly.

Alex’s dad is the engineer @PSA best able to solve this problem and I’m sure will respond if you email your above post to Alex and cc to davep@psaudio.com.

Since it is the weekend, perhaps take a look at where and what the cover might be touching and ig any board or wire or connection might be loose. The dac will function with or without the extra ground wire so I suppose you could try disconnecting it to see if it makes a difference. {make sure it is not touching anything while disconnected.]

Otherwise enjoy the weekend listening to music [ cover off] and the boys will take care of you on Monday.

Sorry for the hassle.


#11

You can email me directly paul at psaudio.com I should be around today and will check.

If Alex said it powered up fine then it did. If the unit is warm then it must be getting power so no need to check fuses.


#12

I sent you an email