Why do some discs take longer to load on the DMP?

Since updating to 3.14 the DMP has pretty much been glitch free with discs loading quickly for the most part, with the exception of some, which can take up to 13 seconds to start after hitting play.
Does anyone have any idea as to why some CDs are taking longer to load and play?

Not encountered that, Gary. My DMP responds quicker on every disk now.
Have you tried power cycling. Older firmware then back again, etc.

It seems to be happening more lately, and a few times I had to power cycle to get any of the controls to work. Haven’t tried cycling back to previous firmware then reloading the current one.
I’ll give that a try. Thanks.

Could be laser mech getting lazy… !?

Hopefully not, my DMP is still a young pup.

OPPO mechs are generally pretty well reliable. I’ve owned two OPPO players never had any problems… But, time will tell. If it starts taking longer and longer of reading TOC !

i always wait for the dmp to complete the toc and graphics download before hitting play, eg wait for the check against the SD-card list, the online d-base(s) queries.
If the disc has been previously played it’s usually speedy but more obscure discs still take time.

I’m not using album art, but I do wait until the disc has been read and all of the pertinent information is displayed, then I push play. Most CDs start immediately, but I’m starting to see more and more of them taking over 10 seconds before the music starts.

Could be a dirty lens or slight laser focus or misalignment, causing it to read and re-read the TOC and error correct. I don’t have a DMP and I don’t know if there is an alignment procedure the end user can do or not.

I have found some discs will load up but when you select a track or hit play it will act like it is going to play than nothing happens. Eject the disk start over and it is fine! Barry is working on this one.


I’ve tried that and nothing changes. The other thing that’s happening, is the player becomes completely unresponsive and I can’t even eject the disc, at which point I need to power cycle the unit to regain control.

1 Like

Very good to hear that as that issue is a very frequent and annoying one on my DMP.


I’ve had that happen a number of times too. Hope Barry can resolve that one too!

1 Like

Has anyone ever had there DMP do this? One day after a quick power hit (even with the P-10 powering my whole system, the DMP started to make awful noises that increased in frequency and loudness. So loud that I was afraid it was going to damage my irreplaceable tweeters in my B&W 800’s. Thank God I shut it down before that occurred. It was very scary!

So the DMP was sending out a corrupted signal of sort to downstream components, following a brief power interruption, that put the speakers at risk of physical damage? Whilst playing a disc, or not?

1 Like

Hi Six,

It’s been a while…

Never experienced that phenomenon…thank god. Sounds Scary!

1 Like

You didn’t by accident spin a Merzbow album? Just kidding… never happened to me. But I encountered another bad behaviour of my DMP lately while listening to some Stockhausen CDs. He divided recordings of his long works into many short tracks on the CDs (many have the maximum of 99 on them) to make it easier for his students to follow what’s in the score. Whenever a track is approx. 4 seconds (representing one or two bars in the score), the DMP will stop for a fraction of a second and replay that short track before continuing. I really hope, Barry will look into this!!! Of cause, track lengths so short may be very rare… but needless to say that no other disc spinner in my house has a problem with it. Crazy!

1 Like

There was a disk in the unit but it had not started to play. The DMP spontaneously created the most awful noises I have ever heard. I have no idea where they came from.

OK, so it wasn’t a noise coming from the DMP. It was an errant signal on the output of a DMP at idle that manifested itself as a noise at your speakers that was potentially mechanically damaging to the tweeter. Did it sound like the noise you get when you bitstream to a DAC that doesn’t accept digital bitstreams?

It is very hard to describe the sound it kept rising in frequency and level I quickly shut the DMP down and averted disaster. I believe it originated after the Oppo portion of the DMP but cannot say that for sure!