DMP Dead Out of the Box [Solved]


#1

Just got my brand new DMP, purchased directly from PS Audio. Unpacked it, hooked it up, and tried to fire it up. It gets to the point of showing a blue screen with “Initializing” displayed, but it just hangs there…

I tried power down-power up several times, no difference. Then I tried downloading the 3.10 FW, unzipped it onto the SD card, and attempted to load new FW to it. Looked like it was loading the firmware, but then when I restarted it gets to the same spot and hangs up.

Any suggestions?

I really don’t want to have to ship it back to PS Audio…


#2

How long have you waited while it initializes? It takes longer than one might expect and at first appears to be doing nothing.


#3

Thanks for the quick response Elk.

After typing my initial post, I went in and took a quick shower, then came back out to my listening room and sure enough, it was asking me to insert a disc!:star_struck: I threw one in, played a couple tracks, then just out of curiosity I decided to try cycling power again. This time, it came up in less than a minute, and seems to be working just fine.

I had read the forums related to the DMP before I ordered it, so I knew that many users had experienced functional “anomalies” here and there, so I guess I knew what I was getting myself into. Seriously though, the first few times I tried to get it to start, I waited at least 5 minutes before cycling power again. Never would have expected that.


#4

Yes!

Wonderful news.


#5

So, I guess we can change the title of this topic now. It wasn’t dead, just a little sleepy to start with.


#6

The secret is taking a shower. The DMP is very sensitive . . . . LOL


#7

Or those pesky gremlins decided to move on to the next DMP…:exploding_head:


#8

To be fair, I had just gotten home from playing golf, so it’s possible that the DMP took offense to the way I smelled…:joy::joy:


#9

I am curious when you rebooted after the machine finally did initialize how long did it take the second time? In my experience the DMP initiallizes much faster than the DAC and even the DAC has never taken 5 minutes.