After unplugging DAC for a while it doesn't initialize anymore


#1

I had the DAC unplugged for a few days. It was working prior. Went to plug it back in and nothing. I can see some green light through the back panel but nothing up front lights up at all?


#2

That doesn’t sound good. Have you tried pushing the On button on the remote? If the DAC is starting up with the display turned off (which I don’t think is should) this will turn it back on (pressing Dim turns the display off). I assume the unit has been turned on at the back panel.


#3

Yes I just tried the remote in case and nothing is working. The DAC was fine when I unplugged it that’s what is concerning. I have it hooked into a Niles with other components and unplugged that from the wall… I was going to be leaving for few days and in case of storms etc. I unplug it all as part of the leave house routine…


#4

Doesn’t sound good. I assume you checked that the power cord was firmly inserted in the back as well as into the Niles.


#5

You might open it up and check the fuses. It is possible that one of them was on the edge and blew when you plugged it back in.

J.P.


#6

I have the exact same problem as Randy. Was there any solution found? My unit is under warranty, but hopefully it’s only a matter of a fuse or two?

Thanks in advance for any advice,

Dubs


#7

A blown fuse is a possibility.

We can all forget to turn off the main power switch before plugging it in, and then switching it back on as well. :)

Another possibility is corrupt firmware. I would try loading firmware one version earlier than the one you are running just to see if this fixes the issue.