Has my DirectStream DAC Failed

I woke up this morning to find the blue power button on my Directstream DAC flashing continuously .
I have power cycled the DAC several times , with and without the SD card installed . I have reloaded Sunlight firmware to a spare SD card but nothing has fixed the issue .

Any suggestions ?


Did you unplug it?

Yes , unplugged power cable and ethernet connection . No Is2 connections.

Time to call PSA. I do hope this gets resolved quickly.

Good luck.

How long did you leave it unplugged? I would leave it unplugged for at least 24 hours and try it again.

I found a couple other threads relating to this. One with Elk I believe but no real fix. Reboot, take out SD card. FW download etc. Hopefully PSA can help…

Have you tried the DS Boot Rescue from the Downloads page (at the bottom)?



This is what I recommend doing here. That should fix it. ^^^

1 Like

Yes, if the recue doesn’t work, it’s time to give us a call and bring that guy to get fixed up.

I have had it unplugged anywhere from 1 - 12 hrs . No change , won’t boot

Thanks tak1313 ,Roninaudio &Jamesh.

I have tried the Boot rescue firmware , once last night and again this morning with a fresh download .Still stuck on the Flashing Blue power button .

Jamesh , I`m in Australia , who does the repairs here ?

Same thing happened to mine. After a couple repowering attempts, got to the point where nothing worked - even the display was dark.

Sent back to PS under warranty - still costs me $125 to ship it. I got it back two weeks later, working just fine.

Being an engineer, I wanted to know what was wrong. I got very vague answers involving “a firmware problem” and “a bent card holder”. Not at all satisfying.

In general I have had very bad experiences with PS reliability. Over the years I think I’ve had seven different pieces - each one of them had to be returned for service. Some more than once. Disappointing.

@paul56 You’ll want to reach out to Magenta Audio. Fantastic team down there and always pleasant to work with. Mike is our guy down there and he’s great. mike@magentaaudio.com.au

@ampicoj Looks like it wasn’t anything too critical. The notes as I see them.

Powers on but display doesn’t come on. Loose ground. Display wouldn’t accept bootload. Test display bootloaded and updated firmware.

Replaced display and PCBA.

Reset Unit ID. Passed AP. Needs new metal bracket. Leaving in burn overnight for testing.

Thanks , Jamesh .I will contact Magenta next week after the Easter break is over . Could this be a fuse issue ? . Im looking through previous posts about the issue and found one that had a blown fuse .

Happy Easter to All

1 Like

Hi @paul56,
I am in Sydney.
I have modded the DSstream DAC myself (Transformers, Linear Power Supply) so I am familiar with the innards of it. If you are in Sydney, pm me.
Happy Easter mate.

You say in your original post that the blue power button was flashing. Therefore the fuse should be OK.

I was looking through the forum and found someone that had a similar issue that was fixed by a fuse replacement . My first thoughts were if the power button lights up then the unit must have power .Trying to understand if there are separate circuits involved .I know the process to remove the lid but I don’t have the all thread required so that I can check the fuse .

It’s a long shot, but what size SD card are you using, and what format did you format the SD card in (FAT, FAT32, etc.)

Thanks Tak , i`ve tried 2 different SD cards . A 2 gb and a 4 gb . Both formatted to FAT .

Some time ago (like a long time ago), a lot of people were having difficulty with updates, and if I recall, the Bridge rescue.

What appeared to work better and was actually recommended by PS was to format the SD using the official SD card formatter from the SD Association called simply “SD Card Formatter.” Another issue (if I recall) was that it was getting difficult to format cards in FAT16, which at least the Bridge Rescue required.

On a long shot, here is the link to the SD Card Formatter program from the SD Association:

1 Like