Airlens not playing

Hello all

Yesterday I installed my PS Audio DAC Mk II and the AirLens - all went smoothly both worked no problems. This morning I have played a SACD on my PS Audio Transport fine no probs. I then switched to Roon and attempted to play an album , AirLens is selected via I2S - Nothing. I changed source to my iPad music plays - back to my AirLens nothing - shows that it is playing in Roon - no sound thru my system ???. I am via Ethernet on my iPad. On my DAC Mk II is shows AirLens as destination source. I have switched on and off , no change . I have also turned DAC on/off - still no music .

This is new - I may have missed something . Any suggestions.

Did you try swapping inputs with the cd player (maybe a cable/connection problem).
If that doesn’t work, try a coax out of the Ailens. If that doesn’t work, then it’s an Airlens connectivity problem. (Or dead airlens)

I’d also check the back of the AirLens. Is the light at the back flashing orange/gold?

Ah yes it is flashing yellow /gold

:+1: Can someone tell me why AI and all the rest has not evolved to the point where we don’t have to futz around with computer settings at all. Are we still evolving towards standards that will make this possible?
While I’m ranting, this seems to be the only weakness in the PS Audio hardware. No doubt their components sound great. Communication dependent functions not so much. Maybe Conversdigital could step up their game.

No, as when I removed the HDMI cable the I2S disappeared from the DAC screen and a red dot appeared. I tried to do a factory reset as suggested the flashing yellow light wont go red as suggested ???

There are alot of posts about the connectivity problems with the Airlens. Maybe just power off and on will do it. Maybe the WPS button. I don’t have one, but I’d try that.

I have trued most things they reccomend in the Instruction Manual with no success . I have spoken with the PS Audio agent here in Australia and he is sending PS Audio an email . Suspect I will have a new unit in the next couple of days :disappointed:

Hi Brud. I had the same issue.
Have you loaded the new AirLens firmware 2.7.0? You will need to do it from a USB stick.
Go to the downloads page to grab the .zip file.
Instructions are in a PDF in the archive.

Good luck!

Thankyou I have now read the many posts and had determined this was a known about issue solved by 2.7 firmware . Loded and issue has been corrected . Unfortunately part of product development , its not feasible to release the perfect software . I love my Airlens :blush::+1:


There’s no such thing as perfect software.

Happy to hear you got it sorted and can now enjoy the music!