BHK Pre - Volume jumping around with 2 PSA Remotes

Hi all,
I have a weird situation that has suddenly appeared with my BHK Preamp remote. It has suddenly got a what I can only call a ‘sticky Pre Volume’ rocker button. Sometimes it increments by 1, sometimes it can go as much as 8 steps in one go! I know that sticky buttons on remotes is possible and that disassembly and a clean usually fix the issue. I haven’t done that yet.
Since I do have a brand new remote never used that came with DS DAC I thought I would use that until next weekend when I could attempt to take the remote apart and clean (Anybody done that?).

But … a very similar issue with the brand new remote !!! jumping on volume up and down at random increments. Replaced batteries in both remotes - to no avail.

This would tend to indicate the behaviour might be with the Pre amp itself?

Does anybody have any clues here?



Does the symptom exist when the remote is just inches from the IR receiver on the Pre?

Hi vkennedy61. I did try moving up closer when I identified that it was more than just a sticky button. I got to about 5 feet away - and the issue still persisted. It was only the volume that seemed to misbehave - all other buttons/controls worked fine.
What I did do however, is completely unplug the Pre power cord from the P15. Left it for a few hours and retried. This seems to have reset it and now works perfectly with both remotes. I will reserve judgement for a few hours of power up just to see if the problem persists - but so far, so good!
I’ll post the results of extended power up time just the same in case it is a heat issue.


1 Like

I am waiting the return of my BHK Preamp that had what looks to be the same issue. I actually have two BHK systems and one unit had a runaway volume control both higher and lower. Because I have two of everything I swapped the remotes and systems. The remote swap made did not resolve the issue and the bottom line is different remote,room,system made no difference.

Well, I hope Kevin’s power reset solved his problem.

Mark - it will be interesting to learn what PSA repairs on your Pre.

Good luck with that. I too wanted to know what failed at the component level that could have caused a disaster but the best you will get is the main board failed test and was replaced. My failure was different though in that the remote was not involved and the displayed level stayed the same while the actual gain went through the roof.

Hi all,

I decided to leave the system on all overnight - just checked - and the preamp volume via remote still working normally - no ‘sticky’ button drifting either up or down volume.

I am hoping that this is the end of this issue … but will pay close attention. It wouldn’t have surprised me if heat might have caused this condition - but it seems to have passed the overnight test. I did forget to mention that when I did have the problem - the volume knob worked fine. I would have expected that to also have been playing up. Maybe - the problem was with the remote receiver interface with the pre-amp for volume codes got a bit scrambled? Now I’m theorising!
I’m just grateful that it is back working again.
The ‘old’ fix of ‘try turning it off and on again’ seems to have worked here!
I’ll keep you all posted if it happens again.
PS: Now to wait for DS DAC II reviewer comments!

1 Like

Hello again. I had my unit disconnected for weeks upon reconnecting it worked correctly for two days then the volume problem restarted.

Thanks Mark for the update here … not exactly what I wanted to hear.! :frowning:
I’ll be keeping a close eye on the issue over the coming week and more for signs of it returning. If it does, I would have to say it would be a definite fault.
Keep us posted on what the diagnosis & repair was on your unit.


Hello Kevin
My BHK Pre was a signature version,Bascom signed it, anyway it was an early version as changes always happen over time. The repair tech called me and I explained the problem to him. He decided that trouble shooting my not be the most productive path so I have a new main circuit board. Perhaps he intends to isolate the problem when time permits. Don’t know if he replaced other components but the circuit board is new.

Thanks for the update. Glad to hear its all back to normal.
Mine is still working fine so maybe just a one off glitch.