Bit Perfect.... Or Not?

Hello everyone!
I use the DS snr exclusively with BridgeII and JRiver 22. I thought I’d give the 2 bit
Perfect files a go which are in the resources section. When I run these I get a solid green tick, however the words Bit Perfect only briefly flicker on and then disappear.

Have I got an issue here, or is this correct?

Many thanks

The bitperfect should stay on as well, except possibly if you have the test tracks looped and then the transition from end to beginning may fail if your source isn’t perfectly gapless (and I don’t think JRiver MC 23 is, but I could have my copy misconfigured.) If you have a volume setting somewhere that’s just a little off (or other almost benign DSP) then the first fraction of a second will be correct until the difference between the perfect file and the output of the player differ by a whole bit.

Thanks for you quick reply Ted. Ooh, that’s alarming, what could be wrong? Is this possibly a Windows setup issue? i’ve Not installed any BItPerfecting software which I know you have to do if using USB. Or can it only be JRiver? Apart from the volume slider on the iPad jriver app what other volume settings are there?

Many thanks

Just checked and I’m actually only running MC22, is there any sonic improvements to be had by upgrading to the latest?

There’s the windows volume control (and DSP, and enhancements…)
JRiver has 4 (3?) different volume control options: I think “internal” is the best in that there are fewer volume controls in the audio path and fewer chances for things to go wrong. If you are using WASAPI as your output you need to go to the Windows sound options applet, the Playback page, click on “PS Audio…”, then click on Properties. Then in the Speaker Properties dialog that comes up you need to check that the Levels tab has 100 for the volume (and you should probably also click on Balance and verify that they are both 100 too), on the Enhancements tap click on “Disable all enhancements” and finally on the Advanced tab make sure both “Allow applications…” and “Give exclusive mode…” are checked.
If you are using ASIO you may or may not need to do the same thing.
I prefer to use a little more buffering for ASIO, WASAPI, etc. than the default, if your buffers are too small you’ll get little drops outs which can also match your symptoms. Around here somewhere is a JRiver setup guide, it’s a little stale, but the audio properties haven’t changed much over time.

I’d stick with MC22 if you are going to play DSD unless you have need of some other enhancement they’ve made. I just had better luck with DSD on MC22 than MC23, but I could be misconfigured (I use the nerdware foobar2000 as my main player so I’m not an expert on JRiver MC.)

Thanks Ted, I’ll stay with MC22 then. I’m using Ethernet/Bridge so I thought ASIO and WASAPI doesn’t apply

Oops, if you are using the bridge you have a different set of options to worry about. There’s also a setup guide for that around here and I know even less about it :slight_smile:

Yep I followed jriver setup when I setup 1st time around. So it’s defo jriver I need to look at then?

I don’t know if it works for the UPnP output but under the player menu (at least on MC23, I seem to remember it on the Tools menu) there’s Audio Path which will tells you what’s happening to the audio.
There’s no volume (or other processing) to adjust in the Bridge or DAC so the source is the most likely place for something to go wrong. It’s possible tho unlikely that your network is dropping packets…

I’ve got Output Format set to ‘None’ and all the other checkboxes unticked on that JR screen. That’s correct isn’t it?

I haven’t noticed any problems with JRMC23 on the Mac. But maybe I haven’t looked hard enough (or mixed a lot of PCM and DSD files). I’ve never notice a significant sound difference between JRMC versions so if 22 works better for you I’d stick with it. I also wouldn’t worry about the bit perfect test too much if DSD files are playing properly.

What made me try the bit perfect test was the fact that the tonal balance changes as I use the volume control on the JRiver IPad app and I believe it shouldn’t. I mainly play dbpoweramp ripped flacs. For example with volume set to :
100 there is slight sibilance and very subtle distrortion on vocals.
99% sibilance goes
98% treble sounds a bit rolled off.
So I need to get to the bottom of this

If you are using JRiver’s volume control, than I don’t think it will be bit perfect. Try using the ripper in JRiver, and see if you have the same problems. I am not using a Directstream, and am still using JRiver 21, with Wasabi playing a variety of downloads, rips, and vinyl digitized at 24/96. I think most of the important settings are in the Options section. But like Ted said, using the Bridge may involve other settings. You could also try running a USB connection to see if you have the same issues.

I think it may depend on the JRMC settings. If it is changing the volume in the software then it is not bit perfect. If it is controlling the volume on the DS, then it’s not affecting the bits. In my case I believe the volume slider on JRemote does change the DAC volume but I never use it so am not sure (and I’m not home where I can check).

I’m relatively certain that JRiver doesn’t modify the volume when set up for a DLNA server (options>Media Network). Using the volume control on JRemote changes the DS volume only (the volume slider on the DS moves in conjunction with the volume slider on JRemote). (note, any setting under options>Audio is ignored when using a DLNA device).

Make sure that there are no DPS options selected (options>Media Network>… Add or configure DLNA servers…>Advanced>… DSP Studio…). For example, I use volume leveling (R128 algorithm) for parties. This will defeat bit perfect playback.

Also under Advanced, make sure the Format is Format: PCM 24 bit and Mode is Mode: Specified output format (these selections will trans-code everything to WAV before it sends it to the DS). This will work with DSD was well (DoPE standard). Feel free to experiment with this. This does not affect bit perfect playback. Just my preference.

One last editorial item. I started out with MC 17 and am now on MC 23. I don’t see any reason not to upgrade. They have made some changes in later versions of MC 23 to the DLNA implementation that just work better. My DS is nearly instantly recognized by MC (I do have my DS on a fixed IP as well as the server and control point).

Sorry, one more thing. I always recommend anyone using DLNA on JRiver to run this program.

Media Renderer Analyser by Whitebear

Whitebear is a frequent participant on the JRiver website. Typically can be found under the Media Network sub-section.

Thanks amsco15, I knew that transcoding to wav was preferable but didn’t know how to do that. The iPad app volume slide is definitely linked as it moves when I use the remote volume control. Am I the only one that finds the tone changes when different volume levels are set? In particular treble roll off

Ted, what issues are you experiencing with DSD file playback with the current JRiver? I’m just curious what the problems are. I’m having some issues with DSD128 files and I’m wondering if it’s JRiver causing the problem.

If you’re playing DSD 128 through the Bridge it will not work. DSD 64 is the limit with the Bridge.

I’m using a Sonore Signature Series Rendu. Supposedly the limit is DSD128 via DSF or DFF files sent to it via UPnP. It will even do native DSD via the I2S output as long as you don’t send send it via DoP. However I currently have an issue where only DSF/DFF files sent as DoP work and only up to DSD64. Oddly enough, when I try and send DSD128 files via DoP it ends up working but the Direcsttream is reporting that what it’s receiving is only DoP DSD64. I cannot get DSD native or anything higher than DoP DSD64 through the Sonore SSR. My current theory is that my router is the reason why I’m having an issue. It’s limited to 100 megabit throughput not a gigabit. I’m thinking that maybe my router can’t stream these large DSD files fast enough. I purchased a gigabit router and it should be here tomorrow to test out.