Bitperfect FLAC vs WAV on DS MkII

Has anyone else notced problems playing the WAV Bitperfect test files. I’m using these - which I think are the latest ones intended to work on the MkII -

The older Bitperfect files provided during the MkI era don’t seem to work in showing bit perfect data transfer. I’m running them to my Rose RS130 and then to the MkII. The FLAC files show the highlighted “B” and the correct sampling frequency/bit info on the MkII display. But the WAV files both show 44.1/16 and do not show the “B” for passing bit perfect data.

AFAIK, the files are the same. I don’t use (or have) the .wav files though. I only have .flac and .AIFF. My MKII consistently shows the “B” for passing bit perfect.

Do the older files (if you have them) not work? They’d have date stamps of around 2014.

They work just fine (at least the ones I have). I’m not sure what the date on the files say. I’m at work. Looks like I imported them into JRiver in 2021 but that’s not definitive information.

Hi Tony, just received the RS130 myself yesterday. It sounds wonderful right out of the box.
Just a quick query: do you connect through I2S, USB or other?

Reason for me asking is that through I2S (native or DoP) and playing DSD256, the music gets downsampled to DSD64. Playing DSD through PCM results also in downsampled PCM. With USB DSD256 is ok.

Probably some remaining software development on the part of Rose to implement proper settings on the I2S iinput/output?

Job, I use I2S and all bits and rates, including DSD256, play and display correctly on the DS MkII. Did you go to the Audio output screen on the RS130 Settings panel to make sure no sampling for anything is selected? That screen is not intuitive - there’s no “gear” icon in the I2S box, which would suggest you can’t make any modifications for that interface. But it turns out the gear icon in either the USB or AES boxes are actually not specific to those outputs, but either of those gear icons apply to all outputs. It’s a confusing bug that I’ve asked them to fix - there should be only one gear icon on that screen, outside of any of the interface boxes. Anyway, go into the gear screen and make sure no internal sample changes are being done.

Thanks for your reply! I will look into it tomorrow night, after returning home and report back.
Good point to take a look into both settings, wouldn’t have figured that out… I do hope that’ll be the cure. :slightly_smiling_face:

Good luck!

1 Like

Update: I’ve been playing around all evening and don’t seem to get things working as they should. Right now, I realise I didn’t tell, nor asked about Roon. Roon is my main player and I use a Synology nas with nsf as music library. As I didn’t have time yet to set smb and connect the Rose to the nas, I haven’t yet used the Rose app.
Just now, I’ve inserted a USB Stick with hires music. And hey, what do you know: now I get that dsd256 reproduction flawlessly!
Let’s see tomorrow how the Rose (app) will handle that nas connection. For now, my guess is that Roon, or the Rose driver, don’t go higher than dsd64/pcm192. Hence the downsampling.

That would be troubling, if you’re right! I’ll ask on the Rose forum if anyone has gotten their RS130 / Roon combination to go past DSD64.

That’s really helpful. Thanks in advance!

I’ve just connected the Rose and nas over smb. Here dsd256 is also rendered to the dac in dsd256. So, we can check the box on that one, as not an issue on the part of the Rose.

Okay. So in that manner it works the same as mine. Thats good. Is it possible it’s some sort of option set incorrectly in Roon?

This just in -


That I didn’t find out yet. I’ve been going back and forth through all menus, but haven’t stumbled on anything useful or that made ring bells.
It can’t hurt to do that once more. :smirk:

Btw, I’ve registered on the Rose forum this morning as well and came across your post. Thanks again!

1 Like

Just came across the following quote from Rose’s RS130 Roon certification announcement:

#1 The Roon Ready feature can only be used if Roon Core is installed on a PC or NAS, or if you have a device that supports Roon Core.
#2. There is no separate menu related to Roon in RS130.
#3. Roon Core must be rebooted for Roon certification to apply and for normal use of RS130’s Roon Ready.

I didn’t previously perform that #3. However, after I did, there’s no improvement. Roon keeps on telling me that the combo Rose/MK2 has a highest resolution of 32-192 (dsd64). In addition to #2, there isn’t a separate menu in Roon related to the MK2 either.
BTW, Roon Muse settings are completely disabled. On the Rose settings - audio settings, I’ve enabled the testing the sample rate when setting up a dac. Software volume control is off.

For now, my guess is that there’s something with the Direct Stream driver (through Rose) that failed some Roon test and therefore Roon is limiting the maximum resolution in both pcm and dad. That makes me curious if my guess is correct, Roon notified PSA and Rose/PSA/Roon are acting swiftly to overcome this hurdle.
For those curious: yes, one can hear the difference between dsd256 and 64, although subtle.

1 Like

Update: just tried to play a dsd256 through the Rose app. It didn’t play like before.
Now the dac display was showing a hickup in grasping the data rate: dsd256-705.6/01-705.6/24, quickly alternating (while the Rose has a 500 msec DSD delay time).
Probably that’s the culprit (making Roon downsample to dsd64 and the Rose to not play at all in this resolution). Further explanation in above posts.

I’ve also tried to revert the soft- and firmware to 2.3.6/198 and then back to 2.6.2/228. Both having the same result as before.

@Paul : can you, or someone from your team, please be of assistance?

Paul does not monitor the forum nor get PMs.

If you need help I suggest calling PSA service Monday morning.

Thank you Elk!
As I’m in the Netherlands, I’Il first contact my distributer.

1 Like

I do monitor the forums but definitely do not get any PMs. If you have a question or need help you can always email me directly . I am typically online 7 days a week.


Thank you for the clarification, Paul.

I am sorry for passing on inaccurate informantion everyone.