Bridge II Input Missing

I normally use USB from my server but had connected another device via ethernet and could not find the input. I thought I was losing my mind since I have used this input before. I went to the firmware screen and the Bridge shows “None”. I am on Snowmass 3.0.5.

What could have caused this? How do I install the Bridge software (I have an SD card)? Can’t seem to find the Bridge download (is it integrated into the Snowmass update)? If yes are people still having issues with Snowmass 3.0.6? New to the Sr (coming from the Jr which was updated via the internet).

Thank you

If you do a forum search for you’ll be swamped with information to chew on.

There is no Bridge II software to download. Shutdown your DSD Sr and unplug it for five minutes. Also, do the same for your router(s) . Start your router and wait until it is done booting up and Turn o the DSD Sr.

Let us know if that fixes the problem.

Unfortunately this did not work. Still no Bridge input. Maybe PS Audio has some thoughts

Are the lights flashing in the back where the Ethernet cable is plugged in? If they’re not, the Bridge is not connected to the network. I recommend giving our tech support guys a buzz and see if they have some suggestions for you.

@fdemello try to power off DAC for couple of minutes and then power on, wait until it’s booted up (shows input on display) and then go to check firmware screen again.

i had the same situation just today after i powered on audio gear after about a week (normally i run DAC 24x7, just this time it was disconnected from mains)

They are. I’ll contact support

No response from support…

Did you send them an email or did you try and call?

E-mail. Tied up at work

Try sending TJ an email directly. He’s one of our go to guys to work through quirky Bridge stuff.

Will do. Thank you