Problem with Bridge II in DirectStream


#1

Hi - I have a new DirectStream with the Bridge II installed. For the first few weeks, the bridge worked just fine, but all of a sudden today it does not show up as a source option. I’ve tried pulling it out to re-seat it but still does not appear (it will also no longer light up the port when connected to my network). Everything else on the DAC works just fine.

Any troubleshooting ideas? I’m not sure if I can re-install the DAC’s firmware (or if there is firmware to re-load for the Bridge II).

Thanks.


#2

Re-boot the network chain all the way back to the router including turning off the DS by the rear switch and then turn it back on in order with the DS last.


#3

Thanks for your suggestion. Turning everything off and restarting was one of the first things I tried. I also completely pulled out the bridge, let the unit power back on, unplugged and re-installed the Bridge; it still did not come back online.


#4

I had this happen and could not resolve it with standard troubleshooting techniques. I ended up have to load the Bridge II rescue software to fix it. https://www.psaudio.com/wp-content/uploads/2014/05/DirectStream-Bridge-rescue-files.zip

You may also be able to flash the firmware to Yale or some early iteration, then reload Redcloud. Sucks to have to go through these types of measures, but it is what it is and getting it back operational is priority one.


#5

My assumption is, it’s either a personal network issue or it can be solved with the latest (currently pulled back)Bridge Firmware. It solves a quite some stuff in case you can pass on cover art and support will provide it to you.

But probably best is to wait for the Bridge update these days.


#6

Which begs the question; how is the update coming, will we see it soon?


#7

Hi antherment,

Sorry to hear that your Bridge II is not showing up as an input.
Please reach out to us at service@psaudio.com and provide the Bridge II’s serial number.
We’ll get you service.
Thanks,

  • Jeremy

#8

Is the software version changed in 0.0.0 that happend to me a few days ago. I didn’t see my bridge 2, looked at the software version of the bridge and 0.0.0 was on the screen. I downloaded software version 3.5.1 into the bridge and everything worked as it should be. Don’t know why the bridge software disappeared???

Ronald


#9

Last info from PS folks today in another thread was, it can take more days or weeks.