Failed bridge update in DSJ


#1

Tried to update bridge last night, Long pressed and got the updating message then a loud pop through speakers (forgot to change input on pre) and then back to main menu, all seemed well. But now I have no bridge connectivity to Ethernet at all and bridge is not even an option for input on dsj. Tried powering off and back up, still the same. Bridge version reads 0.0.0 - any help would be appreciated. Can I load in bridge update via usb or at least revert to version I had? I’m bricked at this point


#2

Have you tried a reset, Power OFF (switch on back of unit), hold the standby button on the front (blue PS Audio symbol), and then power it up while still holding the front switch, you can release the front button when you see it booting up. Worth a try. If you get the ethernet back, try updating with the mControl app on you phone or tablet. Edit: mControl isn’t listed on the app store anymore.

David


#3

Yeah tried that, nothing. Just found a thread where it seems like another user had my same situation - no ethernet recoginzed after attempted bridge update - and he had to send the unit back to PSA. Which… man. Unreal.


#4

BUMMER!!! Sorry.


#5
David said

Edit: mControl isn’t listed on the app store anymore.


It seems to have been replaced by this app:

mconnect control HD

I just dowloaded it and it allows you to update the Bridge II software just like the old “mconnect” app did.


#6

Yeah but remember I have no Ethernet connectivity anymore so that won’t work for me. I have to call tomorrow but like I said, there’s a thread here for a guy from last August who had same situation as me and PSA rep said bridge had become corrupted during update somehow and he had to send it back to have bridge replaced. I have to say, I love the sound but man the thing has been incredibly glitchy on the tech front. For the price I’m shocked.


#7

@David it was me (Bridge2 in DS DAC Sr.) you should contact PSA support - they will try to instruct you how to recover your bridge via software they will send you. I am crossing fingers it will be more successful than in my case.


#8

I will certainly do that maniac. I’m sure this has happened to others - guy whose thread I was reading was username Chris 123. He had a dsj. He had to send it back. What happened in your case manic?


#9

David

If you haven’t done it already turn the DSJ of at the back along with your control point and then re-boot the router. Once the router is back on to normal turn on the DSJ and the the control point and see if your internet connection comes back. During the attempted upgrade the IP address for the DSJ may have changed if you are not assigning fixed IP addresses. If this happened the control point might not see it.


#10

Control point? I am using Ethernet out of a Wi-Fi extender - I know this is not recommended but hasn’t been a problem until now (and I checked the Ethernet connection into my Mac Mini just to make sure - no problem there).


#11

control point = tablet or phone. Even simpler if using extender. First try turning DSJ of then unplug extender, wait 10 seconds plug in and let it re-cycle then turn DSJ back on. I am using a TP Link extender in my “Music Room” and I have to unplug and re-plug about once a week for no reason when it and the Bridge don’t see each other. If that doesn’t work then turn all of and go back to router unplug re-boot and do each piece in order.


#12

thanks jack - no dice sadly. Tried tp-link then did router, nothing.


#13

David

Only other option I can think of is to take it to where the router is and plug it in directly since you may have to send it in anyway.


#14

Called PSA this morning - has the go back to them for new bridge


#15

Can’t you just remove the bridge and send that in for replacement?


#16

The DS Jr and the Bridge 2 card for the DS Sr (and PWD) both use a plug in module that’s the heart of the bridge. In a Jr that’s probably all that PS Audio needs, but ask them for sure. The Jr works fine without the module plugged in (minus the bridge function, obviously.)


#17

Seemed like the rep I spoke to thought sending it in was best though he did say they could send bridge to me and I could attempt the repair myself. I’m not the savviest at such operations so it felt best to let the pros do it.