DSjr - Bridge II stopped working

Hi All,

The network bridge in my DSjr just stopped working this past friday. I reset the unit and functionality came back for about 5-10 minutes (Roon, Spotify Connect), but then just dropped out. A reset no longer brings back any functionality. After checking the firmware/driver status on the screen I notice that the Bridge version says “None”. So somehow the bridge software just went missing.

I tried downgrading from Snowmass 2.01 to Huron and then back up to Snowmass 2.02. This has not solved the issue. I’m wondering if anyone has had this issue pop up. I would appreciate any help!

Note: I’ve contacted customer support as of 5/31/19 and waiting to hear back.


What version of Bridge ii were you running? I would unplug the DSJ for a few minutes, and see if it comes back up. Does your network see the unit?

I was running 3.5.1 I think. Whatever was the latest one. I have turned it off for a while. I’ve connected the Audioquest ethernet cable to different ports on my router. My network cannot see the bridge at all.

Not sure if reflashing the firmware would be of any benefit or not. Hopefully PSA support can get you fixed up tomorrow.

How do you reflash the firmware?

Download the firmware and place on a fresh USB stick, Snowmass 2.02. I have no idea if that would help or not… It might recycle the device, it might not. Personally, I’d wait until tomorrow and touch bases with PS Audio support.

Oh that’s what you meant by firmware. Yeah I’ve gone down to Yale to Snowmass 2.02, back down to Huron to Snowmass, Yale to Redcloud to Snowmass…none of these combinations have fixed the Bridge II issue. I will just give PS Audio a call in the morning and see what they say.

Probably the best way to go. Bridge could have failed. Hopefully, it’s under warranty.

I’ve gotten away from using the bridge much, and have been feeding my DSJ with a Bryston BDP-1 and Sonore microrendu…the external sources work better for me.

Yeah I think it’s possible the Bridge has pooped out. I use it every single day as my streamer with Roon and Spotify. I bought it brand new a year ago so I think its still under warranty. I bought the DSjr specifically because I wanted a one box DAC/Streamer solution. I have no space for another component on my shelf and rack!

Glad it’s under warranty. The DSJ runs pretty hot IMO. Not sure if that’s due to the DAC or the Bridge. I put a component fan on mine. Keeps the air in the cabinet moving.

He’s having a Bridge issue. The Bridge update doesn’t come via the SD card, it comes via the network connection. And if the Bridge update is current, then I think you need MConnect tools to flash it again.

The DSJ heat is mostly due to the Bridge. It’s been discussed quite often here.

1 Like

Can you communicate with the Bridge when the computer is connected directly to the Bridge LAN port? i.e. keep the router and switches out of the equation.

Affirm on the Bridge being downgraded via MConnect, but upgraded on line via network. I had to downgrade myself from 3.6.17. I didn’t know what affect (if any) the USB Stick upgrade via Snowmass would do. Best to work it through customer service.

My first DSJ ran like a furnace. I had to return it. It would go fifteen to thirty minutes and quit from overheating. Needed to cool fully before you could restart it. Replaced it with a new one, and had no problems (other than the Bridge ii popping quirk) since.

Yeah I know. And as we know, rare to find two PS Audio products that behave identically. They seem to be, very much so, individuals in their own right.

Yeah the first one was defective. Bought it from an authorized dealer, so the exchange was hassle free. Overall, my experiences have been good. They certainly stand behind their products. Had to send in a PWT with a bad screen…quick turnaround.

So only two failures of PS Audio products for you, and you’re in 230V land. That’s pretty good going.

120v land…California. Power is pretty stable. I actually had a third. A Power Plant Premier that I bought as a demo crashed right after plugging it in for the first time. Swapped it back for a new regenerator.

OK, three failures then. For 120V land you’re probably on the unlucky side of reliability.