Directstream junior: trouble with the bridge

I bought the Directstream Junior a few weeks ago (second-hand).
The bridge worked very well, initially. No issue to use Softs like audirvana (on my PC) or apps like bubble upnp or MC connect (on my phone).
I had to set up new speakers and devices and I probably moved something. The bridge doesn’t work anymore.
No pb with the DAC, yet, but the bridge, it’s a headache. I have changed my ethernet cable (for other cables used for my TV, for example, that works), but it doesn’t change.

Any idea? Any setting that I could have missed?

The best solution usually is to turn everything off in the network chain (devices, switches, access points, etc.) all the way back to the router and then turn them all back one one at a time starting with the router. That usually gets things going again.

Absolutely try what Baldy mentions. A big indicator of whether or not the Bridge is connected to the network is if the lights are flashing in the back. If they are, the Bridge should be connected. If not, there might be a problem with the Bridge.

Thanks, both of you.
I will try and will let you know.

1 Like

Unfortunately, it didn’t change anything.

The orange light is flashing (not the green one).

Any idea?

It still sounds like a network issue but I cant offer anything else. You might try just unplugging the network cable and plugging it back in. If you go thru the front panel settings does the bridge show up and does it have a network address?

Shoot, sorry those didn’t help. If you don’t mind, try powering off the DSJ with the rear switch for a few hours. Then power it back up and see if it does the trick.

1 Like

Thanks, I will try.

FYI, I think I could have an issue with my routeur. I have read that the lights (on my routeur) should be flashing (one fix, the other flashing actually), and this is not what I have. I will call my internet supplier, to see with them if there is something to do (perhaps a hard reset).

I see :

  • Network setup static ; Static IP ;
  • in the screen with the version, I see BRDG: 3.6.86.

I don’t see any network address

It works now with audirvana.
I have done two things:

  • a reset of my router (my box from my internet supplier)
  • a setting in the DS that I don’t really understand (not sure it was relevant): in the settings, I have I think activated something related to the DHCP (now, I have a DHCP IP =

Yet, I still have an issue with my phone. The DS doesn’t seem to be detected by my apps on my phone, but I think I just need to make sure my phone is on the same wifi network… It should be ok.

Thank you very much for your help.

By the way, this DAC is amazing…

I confirm, everything works perfectly.
Thanks, both of you.

Glad you got it going and yes it is probably the best DAC available for the money.


I have heard a lot of people in a famous french forum (and yes, I am french, and french people grumbling a lot is not a legend) saying that DACs don’t have any major impact on the quality of the sound.

When I said that after a comparison with another DAC (the bluesound vault 2), the difference was amazing, they answered that it was probably due to a difference of noise level.

Yet, on the four last lieder with Jessye Norman (Strauss), I felt that that the sound was so much richer, fuller and at the same time natural…

I, too, find there are big differences in the sound produced by different DACs.

Who knows. I think a lot of folks have simply never heard the difference they can have on a system. Well, if they continue to believe it, their wallets won’t be as upset at them. :smile:

There are different schools of thought. Some say spend more on amps and speakers than preamps and DACs. I’ve found DACs to certainly sound different, and what sounds better is entirely subjective, but I have found speakers and amps to have a larger impact on the sound than DACs.

I am new in the Hi-Fi world. Consequently, I don’t have a lot of comparisons…