Cannot update firmware for PSaudio DS Jr


#1

Hi everyone,

I recently purchased Psaudio DS Jr Dac. I am very happy with the sound of this DAC.
Yesterday, I tried to update firmware from Huron to Recould but it did not work. I have followed the instruction from PSaudio such as downloaded the Redcloud files and copied to a blank and formated usb stick however when i inserted USB and turned on the psaudio Jr, the front panel logo light did not blink and never start to load the new firmware, the Jr just ignored to install the new firmware version but run directly to the Huron.
I have tried to search for similar issues however I could not find any others information.
Could anyone have similar problem or know what to do please help me to solve this problem?
Thank you very much!

Linh


#2

Did you just load the files on to the USB drive and not the folder?


#3

I loaded the folder and unziped, then i copied all the files to formated usb stick


#4

If you haven’t already found it there is some more detailed info in the How To section under the “Resources” menu at the top of this page: (https://www.psaudio.com/ps_how/upgrade-directstream-operating-system/)

But you probably want to contact PS Audio support.

Some things to double check:

Check that you are using the software designed for the DS Jr.

Turn off the DS Jr for, say, 5 to 10 seconds before putting in the USB stick and powering it up.

If you go back to, say, the Torreys release before you go forward to Redcloud it might help.

Perhaps waiting a few days for Snowmass might be easier over all.


#5

I had the same problem. Not even the PS Audio supplied thumb drive would load. They sent me a 2nd thumb drive and that did load. I had difficulty with every update, right from the very first release. PS Support will take care of it.


#6

I also purchased a DS Jr recently and had difficulty upgrading the firmware as well. Interestingly, the first pen drive I used didn’t work even after multiple tries and formattings. When I switched to another pen drive (with the same capacity!) it worked.


#7

I’m having trouble with my DS Jr. recognizing the USB stick with Snowmass files today. I’ve tried two different USB sticks but they are both pretty old. I’ve also tried formatting the drives with OSX and Windows 10 just to make sure that wasn’t an issue.

Similar to OP here my DS Jr. doesn’t do anything at all when booted up with the USB installed. It loads up like it would normally with no update. I’ll try a newer thumb drive tomorrow. Anyone have any other suggestions to try?


#8

So you’re saying there is a newer version of the software on the USB than what is installed in the DSJ, but it’s not loading the new firmware at start?


#9

Yes, I have red cloud on the DSJr currently and I have Snowmass files on the USB. When booting the DSJr it behaves as though nothing is plugged in the USB port.


#10

This has been a problem for some, but not for others, for years (since day 1). I don’t think the technicalities as to why is well understood, otherwise they would have fixed it for everybody to work first time every time. The agricultural fix seems to be, sometimes you need to go backwards first before going forwards. How far backwards you need to go might require some trial and error. However, with these reports coming in of DSJ frozen events with SM you might want to mark time where you are on RC until they sort that one out.


#11

Where did you get the USB stick? Many times the way files are loaded onto the stick can make a difference. We’d be happy to help on Monday or perhaps there’s enough help here on the forums this Sunday. The biggest mistake I see people making is putting the
folder itself on the stick or not unzipping the files.


#12

Happy to report that I was successfully able to load Snowmass onto my DSJr by loading Huron first and then skipping over Red Cloud and going straight to Snowmass. I used the same USB stick I was using yesterday but I did change the name of volume when reformatting from “NO NAME” to “PSAudioFirm”. I know that a space in a volume name shouldn’t have any bearing on anything but I figured it couldn’t hurt!

Thank you Brodric and Paul for the quick support and suggestions! I have the house to myself this morning so I am enjoying Snowmass immensely.


#13

Excellent news! Thanks for posting and letting us know what you did.


#14

I’ll have to remember that…


#15

It worked for me too