Unable to Download Directstream DAC Firmware

I just purchased a Directstream DAC (used) and wanted to try some of the earlier firmware versions. I have a PSA account. When I go to Firmware Archives and click on a version to download, it just takes me back to the “Latest Product Firmware” page. A loop. Am I doing something wrong?

It’s doing the same thing to me and I’m signed-in as well. There must be a site issue.

Thanks Joe. Glad I wasn’t missing something obvious!

Same here. There must be a glitch in the system. I haven’t tried flushing the browser cache to see if that helps.

Good idea. I’ll try clearing the cache…

I cleared the browser cache–didn’t help.

1 Like

I just tried it with Edge and it’s a no go there either. I’m sure they will fix it when the place wakes up next week.

There was forum friend trying to download updates
for his regenerator and could not…I followed up
by checking that…it seems that part of PS Audio’s
web is inop for the moment…

Best wishes

Thanks. Guess I’ll have to wait until PSA fixes their site.

I could send you Red Cloud, Snowmass, Sunlight and Windom if you want.
Send a PM with your email address if interested.


That would be great! Email to [deleted]. But I have Sunlight already, so you do not need to send that one! Many thanks in advance!


That’s very nice of you! Please send. You do not need to send Sunlight, as I already have.



I sent a zip file with all of the DSD loads I have here.
If they dont make it let me now.

I have sent off the older Huron, Yale and Torreys.

I am sending thoughts and prayers. A large pile of them. Too many to count.
Some with Purple Fuses.


I think some of the DL links on the site were down over the weekend but they should be back up now.

1 Like

Yes, that is what I assumed. I had several forum members send me various software versions, so I am good to go. A very kind lot, these forum members are!



I deleted your email in your above post in an effort to thwart spammers who may come across it.