Delay in streaming or unsupported file format - New installation using Tidal


#1

Just installed Bridge II into my directstream.

Using MConnect, I’m able to play music to my local player. Change to BridgeII and I get the error message. I am able to consistently control the volume on the directstream using MConnect. Also can see Once the direct stream showed title info but no data rate or playback.

Bubbleup can also see BridgeII and reports back full info.

The instructions are straight forward, but I must be missing something.

Any ideas?

F/W v3.5.1 / Red Cloud
MConnectControl 2.3.9


#2

If you just installed the Bridge II and connected the ethernet cable and nothing else your issue is not all that out of the ordinary. Shut everything down all the way back to the router and then bring everything back on line one device at a time moving on to the next after complete boot up. The DS should be last. Then if the problem still persists log out of Tidal and then back on.


#3

Thanks for the response.

Tried this and no change.

Also uninstalled the apps and reinstalled. Reboot my tablet between each uninstall / reinstall.

Tried MConnect Control HD as well, no change. Went back to MConnect Control

Currently have
BubbleUPnP 2.9.4 reports license found which I bought yesterday, have the license battery monitored
mconnectConrol 2.3.9

removed standalone Tidal and spotify. Never could get spotify to share to the bridge


#4

Try booting up your DAC and then plug the network cable in afterwards. This helped me once when I was having trouble connecting to the bridge and Tidal via MConnect


#5

Brady, thanks , didn’t solve the issue


#6

Will Tidal play to your ipad speakers on the MConnect app if you try that instead of connecting to the Bridge?


#7

Just got off the phone with tech support.

TJ got me going. Turned DHCP on and streaming now.


#8

I have to say I’m completely disgusted with the product and service now.

After turning on the DHCP the DAC worked wonderfully for 2 days. Then it got worse.

Now I can’t even control the volume slider on the DAC through mcontrol.

Current state

Tablet sees the DAC and can read its internal info
Tablet streams to itself just fine
DHCP is enabled and the DAC shows IP connect with a good 4.3 address
DAC is connected directly to the router and all I get is the error message

Called customer support 1st thing Tuesday morning and explained the situation. Did a reboot. Then got put on hold for a minute. When TJ came back all he says is our equipment is working perfectly, its your network.

WTF - what diagnostic test besides its powered up determines that.

Since he didn’t want to help solve the issue and it appears PS Audio can’t or will not help. I told him that I need to figure out how to get my money back. Didn’t seem to be an issue until I said, the DAC needs to go back to because I got so that I could do all this wonderful high quality streaming. Now he offered an advance replacement on the card, but it 2 days later and I’ve not gotten any tracking info on the replacement.

Hopefully Paul will see this, I’d like to know where the support is on this product. What I’m being told by TJ in your customer service department is that if it doesn’t just work we have no ability to help, no skills to help debug, or even scripts to run through to sort out root cause of the failure.

I’m dismayed and regretting my purchase.

I


#9

Yikes! I am seeing this and am not happy. I am on vacation traveling in California but let me get someone on this right away. Please accept my apologies. Can they contact you via email?


#10

Hi doitwithlife,

Please accept our apologies for this delay.
I am re-sending you the paperwork for your Bridge II to the email address we have for you on file and advising that our shipping department please get that replacement headed to you right away.

If you do not mind I’d like to make sure everything is in order by following up with you directly.
You can message me back at jeremyb@psaudio.com or call at (720) 406-8946 ext 2.

Or if you like we can contact you by phone.

Just want to make sure you get that replacement right away.

Thanks and again, please accept our most sincere apologies for this delay.

Kind wishes,

  • Jeremy

#11

Yes Paul email is fine, thanks for responding so quickly.

As I wasn’t sleeping I dug into this and belief I found the problem and a work around

This appears to be an update problem between Mcontrol and the DAC

I found that the IP that Mcontrol was reporting for the DAC is stale. Each time the DAC is cycled it gets a new IP but Mcontrol is still working off the old address. It even reports the DAC internal info although its all stale data and its not really talking. Restarting Mcontrol, or even rebooting the tablet isn’t updating things

Pinging either address failed. Found this to be odd. Going by the IP is a good way to get around DNS issues and surprised that I couldn’t reach the DAC by its internally reported address

I found that if I changed the name of the DAC it then sends updated info to Mcontrol if it is restarted. It worke great for 1 song. Then stopped. Both addresses were the same and I was able to ping the address with 0% loss.

Changed the name again as soon as the new name appeared in Mcontrol it worked again. Rebooted the tablet and its still working.

For now the work around is to change the DAC name to get communication going again. I wonder about using DHCP as the default configuration. With the failing updates with each new IP address going with static IP might make more sense. Until a way to get the IP back up to the software can be resolved.
.
At this point I’m not thinking hardware is going to fix this. Seems to be update / sync issues between the firmware and software.


#12

My advise is to not assume the problem is firmware. PS Audio recently replaced my Bridge II with a newer version. My problem was very minor but the newer Bridge II resolved the issue completely. This is after years of pretty flawless service out of my original Bridge II.

Also, since I dind’t want to be without the Bridge II, they worked out a deposit for the new Bridge II which was completely refunded as soon as they received the old one back. The entire process was very simple and accommodating!!

One last item, I’m convinced that the Bridge II works better with a fixed IP. I use the MAC address of the Bridge II to assign a fixed IP (out of DHCP range) in my router.

Good Luck


#13

FWIW: Ordered BridgeII the moment it was launched and ever since using DHCP as the default. Never had any issue whatsoever streaming Melco (HiRes) files, Qobuz HiRes, Tidal mqa and vTuner. Firmware updated flawless. Really don’t know if it’s because of a robust network or otherwise…maybe I’m just lucky :wink:


#14

We Arte here to help in any way we can. Just keep us in the loop.


#15

Jeremy and I have talked a couple of times today and the last call was an update that we seem to be in good shape but will monitor and keep in contact.

Jeremy has been extremely helpful, knowledgeable, courteous, etc. A joy to work with.

We ended up going with a static IP and doing some reconfiguring of my network. Changing over to google DNS over my ISP provided service added some reliability and the wife says the internet seems a bit faster to her now. Happy wife is a good thing.

I left the DAC running all day and as of now, its still streaming. Again a happy wife again who is again asking for me to show her how this works so she and DJ her music.

Thanks for the prompt service today. I do belief this is going to end well


#16

If Tidal starts hanging up then consider switching your DNS settings to Cloudflare. I had been fighting with Tidal issues for months and tried Google and Cisco DNS on the recommendation of the Tidal people with no luck. Just prior to cancelling Chris Coniker of Computer Audiophile recommended switching to Cloudflare and I have been trouble free for almost two months plus it is faster than the other two.


#17

Soo…what was the actual fix to this issue (which I’m experiencing now)?

[EDIT] Let me cut this first post down. I was having the same exact issues with my network set up “correctly” and optimal DNS servers entered into the settings on my WI-Fi router for Tidal.

Solution below.


#18

Here’s the fix - in answer to my own question and maybe it will help someone in the future.

The answer was simple. MConnect Control for some reason had defaulted to Static IP, which is depicted by two “buttons” at the top of the config screen (under IP Address) for the Direct Stream DAC within the MCC app. This is not obvious upon first approach. Because the DSD screen was showing that DHCP was functioning correctly and the MConnect app was mirroring the IP address (and all other network settings) of my DSD, I assumed that all was OK in terms of the actual connection or handshake between the app and my DAC.

The solution was simply to change the MConnect Control app to DHCP at which point it said it must restart and reconfigure. Just to be safe, but probably not necessary, I cycled the DHCP on the DSD as well and bingo. Once I restarted MConnect Control, songs would play through the DSD.

Problem solved. So…short answer is:

Make sure your MConnect Control App is set to the same addressing protocol as your DSD or DSJ (DHCP or fixed/static IP address). (It’s not readily obvious or apparent without digging into some settings on the app).

  • To do this you must first see the DSD/DSJ in your “Play To” list on MConnect Control.

  • When you have chosen this as your default Play To device, open the settings for the DSD/DSJ in MConnect Control at the top LEFT of the screen. Choose “Device Setup”.

  • Select “DirectStream DAC” or “Direct Stream Junior DAC” from the list (it should be the only thing there).

  • It will bring up settings for the DAC, of which one is “LAN IP”. There is a little icon with some gears for Settings to the right of your DAC’s IP address. Choose that icon.

  • A new screen will appear and at the top it will have two “boxes” or “buttons”: DHCP or Static IP. Choose whichever one your DAC is set to, then hit “Apply” below.

  • You may then need to cycle the power on your DAC, but probably not. The MConnect Control app will flicker on and off and change screens.

  • At this point check all your IP stuff again and you should be good to go.


#19

Just wanted to note that I forwarded this post to our contact at Converse Digital.
This is his very informative and helpful reply:

The IP information is delivered from the DAC to the mconnect Control app.

mControl app just shows the information received from the DAC. The IP status is either DHCP or Static.

For your information, in DHCP mode, the IP address is allocated automatically by the router to the DAC.

And in Static mode, a user set the IP address manually.

Using DHCP is typical to avoid collision of IP address.

At mconnect Control’s Device Setup screen, you will see the Gear icon at right side of LAN IP address.

By touching the icon, you will see the LAN Setup status of the device.

  1. If the DAC is in DHCP mode, the screen is seen as attached DHCP.jpg file.

  2. If the DAC is in Static mode, the screen is seen as attached StaticIP.jpg file.

As you can see, if the DAC is in Static mode, the IP address settings should be seen in the screen.

If you want to switch between DHCP and Static, touch the DHCP or Static button at the screen.

  1. Current mode is DHCP, and change to Static: You need to type in the IP address and other numbers in the screen.

  2. Current mode is Static, and change to DHCP: Just touch DHCP and Apply. That’s all.

In both cases, the mconnect module in the DAC will reboot.

Best wishes,

  • Jeremy

#20

As a former network engineer, I understand how DHCP works, and their statement is simply not true. My DAC has always been set to DHCP, but the MConnect Control app defaulted to Static upon initial download and installation on a new phone and after it detected the PS Audio Direct Stream DAC on my network.