DirectStream DAC and Foobar2000


#1

Hello all,

I would like to know how you have setup foobar2000 to act as a control point for your PerfectWave DirectStream DAC.

I have been trying to get this to work for the last couple of days without any luck.

I have a PerfectWave Transport that does play through the DAC.

I have tracks on the PC with foobar2000 installed and I have tracks on my NAS. I can not get either to play on the DAC.

PerfectWave DirectStream DAC with Network Bridge

QNAP NAS running AssetUPnP as a music server.

Laptop with foobar2000 v1.3.8.

In addition to the standard components I have installed the UPnP/DLNA Render, Server, Control Point (foo_upnp) component.

I can use the UPnP Browser to browse my server and place tracks in the UPnP Controller Playback Queue.

I can select PerfectWave DAC in the UPnP Controller drop down box. PerfectWave DirectStream DAC is not shown.

I do not see the track in the UPnP Controller window and it is not playing.

I can select other other devices in the UPnP Controller window and get music. When the track is playing on other devices the name is shown in the UPnP Controller window.

What am I missing?

Any and all advice is welcome,

Chip


#2

Hi Chip,

In addition to foo_upnp, make sure you have installed foo_input_sacd (if you want to play DSD files) and foo_out_upnp. You should see the Bridge, not the DS Dac, as the renderer in the dropdown menu; choose it. (At least that’s how it looks on my system.)

Are you sure that the Bridge is working properly? You mention that you can play to other UPnP devices, so your NAS seems to be set up properly and visible on the network. If you’re using Windows, go to the Network screen in Control Panel and see if the Bridge is shown in the network map.

I’m not familiar with Asset UPnP–can you use a control point other than foobar to play directly from this server? If you can’t test the Bridge directly from Asset UPnP, maybe your NAS comes with a music server app, or you can install MinimServer (it’s free). Once you’re sure the Bridge is detected and functioning properly, then go back and play more with foobar.


#3

Hello,

I have installed foo_input_sacd (0.7.8) and foo_out_upnp (1.0 beta4) as additional components in addition to UPnP/DLNA Render, Server, Control Point (0.99.49).

I still only see PerfectWave DAC in the drop down selector. (note: I think my device name is different because I gave it a ‘Friendly Name’ in my DHCP sever.)

If I check the Renderer Properties from the UPnP Controller window I see a popup window with the following:
Friendly Name: PerfectWave DAC
Manufacturer: PS Audio
Manufacturer URL: http://www.psaudio.com
Model name: PS Audio Bridge
Model number: 1.0
Model URL: http://www.psaudio.com
Base URL: http://myunitipaddress:50505/
Supported: LPCM (L16), MP3, AAC, FLAC, ALAC, WAVCapabilities: playback, volume
OK

I can ping the DAC using the Base URL IP Address above.

I opened the Windows Network Map on my laptop and I can see ‘PSAudio-Bridge’ connected to my network with the same address.

I can open the device page of the PSAudio-Bridge from the Network Map. Then open Network Status and it shows the same IP Address and Ethernet: Enabled and the other options from my DHCP server. I can access the bridge from the same laptop that I am using to run foobar2000.

I have downloaded and installed MinimServer on my NAS and built up a small library. I can see MinimServer from the UPnP Browser. When I try to add tracks to the playlist they appear in the foobar playlist window as the UPnP Controller Playback Queue but do not show up in the UPnP Controller window.

I can use this network and both music servers with Linn Kinsky control point app to play the tracks on an old Linn DS that is supposed to be replaced by the PW DAC.

I think the the ethernet part of the bridge is working. I do not know how I could test the audio part.

I do appreciate your help and hope this provides more information to allow other suggestions to overcome my problem. I really want to hear this device start playing from my music library.

Chip


#4

and now it is working …

After writing the previous post I rebooted everything with a power down and power off.

After that I restarted the DAC then my laptop running foobar2000.

Now I think the previous post with the additional components actually fixed my problem.

It appears that we need to install at least additional components in foorbar2000 for it to control the DAC.

UPnP-DLNA Renderer, Server, Control Point (component installed is foo_upnp)

UPnP MediaRenderer support (component installed is foo_out_upnp)

and then add the following component to play DSD files.

Super Audio CD Decoder (component installed is foo_input_sacd)

I hope my adventure and magister’s help will help others in the future.

Thanks magister,

Chip


#5

Chip,

I’m glad you got it working; as Gordon, one of our longtime members here, is fond of saying – reboot, reboot, always whenever you have any kind of issue with the DS or other computer audio pieces. You have correctly identified the necessary foobar components.

For you and others, let me make one suggestion that may seem like a small thing but is helpful in understanding how this stuff works. You said you could ping the DAC. Actually, you are pinging the Bridge. Even though the Bridge sits inside the DS, it really is a separate component. The DS purchased without a Bridge offers several inputs; you could play from your computer via foobar through a USB connection, for instance. (After you install foo_out_asio and find the correct settings in foobar, that is, and using foobar’s general-purpose playback, not the UPnP-specific playback.) But ethernet connectivity, supplied by the Bridge, is a different animal from the others in many ways. All the built-in inputs could be functioning perfectly but you might have issues with the Bridge if your network is not sufficiently robust.


#6

Hello,

Please ignore this attempt at a post since I seem to be confused. After I figure out exactly what I want to ask I will be back.

Chip