DirectStream DAC Bridge II just started inserting gaps

I have a DirectStream DAC with Bridge II that was upgraded using the kit from PW DAC Bridge I back in the stone age. It’s been working flawlessly for about a decade but started inserting gaps between tracks this evening just like the bad old days of the Bridge I.

Whilst this frustration with gaps is quite nostalgic for me as a Bridge I veteran, it’s got me baffled. I’ve reloaded the DS DAC firmware and the Bridge II Firmware is up to date. I’ve tried the reset bridge button in the settings but this doesn’t seem to do anything.

Has anyone else had this happen? Any ideas what I can do?

Where did that user name I have been assigned come from too? I haven’t posted on here for years and it’s given me a new identity.

@elk can help you with your name.

1 Like

Many thanks Ted, although the problem with the Bridge is a bit more important right now :slightly_smiling_face:


Your part of the DAC is still working beautifully.

If you’re using Roon/Qobuz, there’s a large thread on the Roon site with users having this very problem….myself included at times. I’m not using the bridge.


Highly unlikely the BII is responsible for gaps in playback.

  1. How did you conclude that the BII is the issue? What steps did you perform to conclude it’s the BII?

  2. What’s your streaming source?

Thanks for getting back to me so quickly - PS Audio is certainly fantastic for customer service.

I concluded it was the Bridge because this was exactly how the old Bridge I used to behave in the same DAC years ago. If you think it’s something else, I’m all ears.

I’m streaming from Qobuz using Roon. The DAC has been really reliable for years. It’s an old Perfectwave DAC that I upgraded with a kit when the DirectStream was first released.



It’s gaps between the tracks by the way if that’s not clear.

@amsco15 is spot on. There are several topics on the Roon forum discussing this issue. Roon has a fix in Early Adopters. Based on what I have read, the fix in EA isn’t fixing the issue for all of the testers.

This has been a know problem for quite some time. Some have the issue consistently, some occasionally. I don’t have the problem any longer since I upgraded to 32GB of RAM. Roon isn’t commenting on a hardware fix because the Roon legion will go insane if they have to upgrade hardware. Roon is working on a fix to how they manage memory caching.

Here’s one of the topics:

1 Like

I’ve owned bridge i and ii. Bridge i was incapable of gapless in spite of many Paul promises to fix it (along with eLyric). Bridge ii was specifically designed to solve that oversight. See above for what I think is the cause.

Thanks very much all of you for this. I’ve had a few glasses of wine, so I’ll investigate it in the morning. It didn’t occur to me that it could be anything to do with Roon.

I recommend a bolder approach. More wine. More investigation. haha


I had another glass and tried deleting my Qobuz login from Roon and re-signing in a couple of times. No change.

How can I play my music from Qobuz through my DAC without Roon? This looks like it’s been going on for months without being resolved so I’ll cancel my Roon subscription. If enough of us do this they might fix it.

Roon eventually gets around to resolving issues. There’s nothing quite like it on the market and it is evolving as time goes on. It’s considerably better now than years ago. Unfortunately they’re big enough not to really care about attrition. I’ve had issues on and off over the years and all have been resolved to my satisfaction. It never happens overnight.

1 Like

Just play Qobuz through mConnect but don’t forget to set it to gapless in the setup. It’s what people without Roon have had to do.

1 Like

When we switched the forum software some user names were randomly reassigned.

Send me a PM with your preferred name and I will change it for you.

This works well. Now that the fix is in EA at Roon, it should just be a few more Sprint cycles before they have it fully corrected. If I were to guess, probably two to four weeks. Which is a lot better then the months that many have waited.

I have not encountered this problem with Roon (yet) … however I have encountered others and deleting and re installing the app on my iPad has always fixed whatever problem I was experiencing. It may sound crazy but it’s worked.

We don’t have the bridge, but we have Qobuz and Roon. About a month ago in the middle of a song roon will go to the next song for no reason (about 1 out of every 50 songs or so).

We contact Roon about once a week, with no answer so far.

1 Like