DirectStream Senior stuck in mute mode


#1

My DirectStream has decided to go into mute mode all on its own.
Some background;
I always leave my DS powered up 99% of the time with the display off, it has been that way for over 4 and a half years.
Recently we went on a 2 week vacation and I powered everything down.
When we returned I went to power everything back up and the DS was a hard start, but it eventually booted and came to life.
About a week later we were sitting down for dinner and there was a “ting” from the music room.
My wife said what was that, I replied probably a tube damper popping off of a tube, thats what it sounded like.
After dinner I went to re-install the damper but none were found to be missing.
The next evening when I went to start my listening session the DS was in mute.
The remote would not bring the DS out of mute, the relay would just click in and out.
Likewise pressing mute icon on the display screen, it would click in and out.
New batteries in the remote did nothing.
I tried powering down and back on, loading the DS rescue firmware and reloading Snowmass, disconnecting everything form the DS and repeating the prior steps all to no avail.
Every now and then, if I start a track playing and press and hold the mute icon, the mute will turn off, but as soon as the track stops, it goes back into mute.
Every now and then, it will work the way it should, but it is short lived.
I am fairly certain that this is not a Snowmass issue, I had no issues prior to the 2 week power down.
If anyone has experienced this strange behavior and managed to solve the problem on their own, please let me know what you did to resolve it.
Otherwise I will have to make a call to customer service on Monday.
It will be a long weekend without music.


#2

Hmm, that’s a strange one.

The good news is, I have a few things that might work.

First, make sure your source isn’t muted. Roon in particular I believe can control the mute on the DS.

Second, (and I’m guessing you have your DS plugged into a power conditioner or Power Plant), try plugging it directly into the wall.

Let me know how those two tests go. I’ll do what I can to get you up and running - hopefully we can get you up and running without having to call service.


#3

Thanks for the suggestions.
No Roon in play.
No source in mute.
I did try bypassing the P300, no effect.

I did get a call into customer service when I realized that I still had time.
The one suggestion that seems to be working was rolling back to RedCloud.
I did not give that a try previously since I ran the rescue and Snowmass hadn’t given me problems prior.
I plan to try to run through as many different scenarios as possible this weekend for when customer service calls me back on Monday.


#4

You might try unplugging it for a half hour (timing isn’t critical, but longer than, say a minute.)

But unless you are using the bridge, the DS doesn’t know anything about track boundaries. If you are using the bridge make sure you are using the latest Snowmass (released a few days (or a week?) ago) and the latest bridge software.

If you are using I2S, please unplug it and try another input without any I2S plugged in.


#5

The extended power down does not resolve the condition.
I do not use the I2S input, my input is via AES/EBU from an isolated output source.
I also do not have a Bridge installed.

I have conducted some further scenarios and it currently appears that the issue is prevalent with Snowmass V1.
Rolling back to Redcloud eliminates the mute with a mind of its own.
Also currently running Snowmass V3 without issue for the time being.
Sometimes V1 will run without issue for a while and then it reverts to muting.
Sometimes V1 will act as though it is working, via manually or remotely engaging and disengaging mute, but as soon as I play a track it will auto mute.
There is also quite a bit of mechanical relay noise when the mute is acting up.
This can be heard when trying to manually or via remote while trying to get the mute to function.
Also, while the mute is in, trying to raise the volume via the remote causes relay chatter and the volume steps are very course or random.
If I turn the display off, when stuck in mute, it will not come back on via the remote power on button or by pressing the power button on the DS.
When I can get the mute to stay disengaged, there is no issue with sound quality.
These comments are all with Snowmass V1.


#6

Thanks for the detailed info.

If it weren’t for changing with changing releases I’d guess either that you had a problem with the 5V digital power supply (that’s why I asked about I2S cable, it can connects the 5V supply to the outside world) or a short on the ribbon cable between the digital and analog cards (or, less likely, a short on those lines on the analog or digital board.)

When including the symptom of the bug changing with software releases and the relay chatter when changing volume it looks much more like a bug in the display/control processor code - the hardware mute takes a specific well defined command to execute (and doesn’t involve the FPGA) and won’t happen by accident. But what is confusing me is that the DS (except for the bridge) knows nothing about starting or ending of tracks or whether the source is paused, etc. With correctly functioning hardware there’s nothing any audio pattern can do which would cause the mute relays to click.

While you are waiting for service, you might think about any other path between your source and the DAC that could change with the changing of tracks, for example, if you are using a remote for your source and that the DS is also reacting to it…


#7

File playback control is via wifi using an Android tablet.
MinimServer with BubbleUPnP app on a SonicTranspoter i5.

I did do a search for a possible IR remote with something laying on it so that it was blasting a flood of IR that might interfere with the DS remote, but none where found.
I thought that maybe the DS remote was sending faulty commands, but then the mute auto engaged as soon as a track started.

Everything was working with Snowmass V3, so I reloaded V1 and for the past 3 hours it is functioning as it should.

Maybe its extraterrestrial interference?