DMP won't read DVD A and some SACD issues

Recently acquired a DSM from dealer trade - in. Everything worked fine until I updated to latest firmware (as it was on v. 2. something).

Now, 1. It won’t read my DVD A disc - only shows 1 track. Before I was able to use the treble clef icon to scroll thru all versions on the disc (PCM, 5ch etc). Now hitting that just takes me to the info menu.

  1. SACD will not downsample to hi res and only outputs the CD layer. I have the correct settings applied.

Is this a known issue with the latest firmware (3.15) ? Will rolling back fix this?
It reads DVD R data discs fine and sounds great on CDs.
Thanks for any advice here.

Welcome @Guydesavoy !

I suggest rolling back to an earlier firmware, and reloading the up-to-date firmware.

1 Like

did you try performing a power recycle?

1 Like

Thanks Elk. Will try that. From your post I assume it doesn’t matter which version we roll back to?

gthiel -Thanks for the suggestion. How do we do a power recycle here? Is it shut down disconnect power etc? What are the steps?

  1. turn the unit off using the power switch on back of unit
  2. unplug unit from power source
  3. leave unplugged for 10 minutes (or however long you like. I question this step)
  4. plug unit into power source
  5. turn unit on using switch on back

Hope this helps


Any version will do.

1 Like

Not playing the DSD layer of an SACD is obviously an issue, and I’m unsure about firmware versions from one to the next, but it’s been my understanding that the DMP was not guaranteed to play DVD-A. This from the owner’s manual:

The DirectStream Memory Player (DMP) is a state of-the-art universal disc transport capable of playing
most forms of optical disc, including, AVCHD, HRx, SACD, CD, CD-R/RW, DVD±R/RW, DVD±R DL.

That said, I am able to get DVD-A to play on my DMP, firmware 3.15, FPGA 1.04

Edit: After a little experimenting, I seem to also have issues with DVD-A with my DMP. Works one minute & not the next. Again, I’m unsure that it’s designed to be guaranteed to play DVD-A. However, on SACDs, DSD layer always plays for me without trouble.


Thanks for all the input.
After powering down overnight I can report (partial) success. I can now play DVD A again but as tuladct noted (thanks again) it can be random. I do have to fiddle a bit before it will read the tracks. For clarity (?) not sure if it is DVD A as the disc I have (King Crimson) the DVD has Mch, MLP and PCM (24/48) so I guess the DMP is just reading that layer (same as for a DVD-R I imagine).

On SACD, I am not using i2s out so it will only read either redbook layer (if hybrid) or - and this is the thing - it should downsample the DSD to hi res PCM, which it used to do… but now I only get DSD, no downsample (correct settings applied). This effectively means I can only play hibrid SACDs that have a cd layer, until I get a PS audio DAC.

Have you tried the downsample function using a different output?

I will look into the firmware re-install when time permits. I’d like the DVD A function to work consistently before I start ordering more discs.

Thanks all.

1 Like