DS IPad Control ?

No need to apologize. I also get confused between my three iPads (I also have a Mini) and my iPhone and this was all some time ago now. Too many devices and fewer and fewer working brain cells (talking about myself only, of course). I think it was the need for iOS7 compatibility that led to the problematic eLyric version (or versions, there may have been more than one). I haven’t heard anything lately about the eLyric controller so I assume no development work is going on.

Frode said Mconnect;

Pos: Sleek and clean interface. I like the colors.

Cons: Unstable, crashes. Looses the renderer, feedback missing at times.

My other app is dead stable.

Post note:

The crashes might be associated with trying to play non-supported audio formats (same as 8Player).

What’s your “other” app?

The Lumin app to control my Lumin player (and that’s maybe an unfair comparison), which again feeds the DS DAC over S/PDIF.

I have sold my PWDII with the Bridge inside, so the DS cannot be controlled directly over IP in my case.

The Lumin app can just control renders that support Linn Open Home (something I hope BridgeII will do). The new Auralic Aries bridge also supports Open Home.


Has anybody found iPad (iOS 7) control point software which works without issues with the DS, Bridge and MinimServer? I have also Linn Akurate DS/1 and have tried these control points with following issues.


Won’t find DS or ADS/1

Linn Kinski

With DS plays only the first track from the album or play list. Works fine with ADS/1.


Won’t find DS but finds ADS/1. Works fine with ADS/1.


Won’t find DS but finds ADS/1. Works ok with ADS/1.


Crashing and restarting very often. Is carshing sometimes with ADS/1.

Audionet Music Manager

Limits play lists only to 10 tracks with non Audionet playback devices.

I am running MinimServer on Synology NAS, but have also Asset UPnP and Jriver on Windows Home Server. NAS, WHS and DS all have dedicated IP address and are in Gigabit router. All the control software above seems to have same problems with Asset UPnP so I guess this is not related to MinimServer. Jriver and Jremote is currently the only setup which works without issues with the DS.

Any advice or suggestions?

The trouble is that the uPnP implementations are way too sloppy making servers and renders interoperable.

Simply put, the standards are not implemented correctly and in full by the contributing parties.

Look at Lumin and Linn. They work perfectly together. Exemplary!

Have you tried 8Player?

It worked well with the Bridge for a while (also for uPnP discovery) but after some time glitches appeared.

Some I think was caused by non-supporting media formats.

Thanks Frode. Tried 8Player briefly and so far it has worked with the DS, Bridge and MinimServer combination.

Did a search in the App Store for eLyric on an iPad2. No such critter any more. The eLyric search garnered Arataki a Plinius “DLNA compatible controller for network audio”. Any one ever mess with that one? Is the bridge even DLNA?

Happy 4th

eLyric was there a few days ago but does seem to be gone down. It still shows on mine in Purchased Apps but did not show on a search and was no longer asking to be updated on my iPad 1. No Idea about Arataki. The Bridge is UPnP but can’t remember if it is also DLNA (which I think is built on UPnP).

I removed it from the app store. We were unable to fix enough of the compatibility issues.

For me so far what worked best (with minimal bridge unavailability issue) is bubble upnp on android (samsung tab 4). I use minim as the server on qnap.

Interestingly in ipad mini i have found elyrics to be the most reliable compared to other controllers. Occasionally whenever i see ds is unavailable (greyed out) i open the web interface from safari in ipad and reset the bridge and the ds immediately shows up as available.



Hi jka

Audionet works perfectly. The restriction to 10 tracks counts for the free trial version only.
Full version cost is $ 6.45.

Hi all. Touch wood, version 2.1.0 of eLyric seems to work fine on an iPad Air running iOS 7.1.2. (With playlist art and browser art disabled.)

That is with an Linn DS player…

I hope this inspires Paul to put that version back up on the App Store.

It doesn’t work on my iPhone 5 (iOS 7.1.2) though. :(.

Superb app. Love the artist info… Has taught me a few things about what/who I’m listening to…! Haha!

Paul is right, Mconnect is a fine player for me.

I purchased the Mconnect HD version and to me it seems very stable.

At this moment the most stable app with quick response.

All important functions seems to work.

  • Picture on the DS

  • Volume control works

  • quick ds find

  • after activating the IPad from sleep mode the displays gives the play info and you are able to control the volume before loggin!!

Using QNAP with minimserver installed, bridge and iPad with latest IOS 7.1.2

I forget to mention i tried:

Kinsky – plays only one track

8player –

plugplayer – second best for me

elyric – you have to restart UPNP server to find the DS

songbook - not stable

Audionet – not stable volume control / no picture

adimon said Paul is right, Mconnect is a fine player for me.

This is encouraging. i will be trying out the mConnect and 8Player this evening. Like Frode, my Lumin app on my Lumin [playing from the MinimServer running on my Synology 1812] is just rock solid. And I do mean rock solid. Firmware updates are automatically processed, downloaded, and installed from the iPad app. My only wish on Lumin would be easier playlist creation/maintenance and an iPhone version.

palerider said

Like Frode, my Lumin app on my Lumin [playing from the MinimServer running on my Synology 1812] is just rock solid. And I do mean rock solid. Firmware updates are automatically processed, downloaded, and installed from the iPad app.


Indeed Lumin app is also great :-)

Different UI

thx guys.

But can someone answer why some album covers are not shown on the DS?

What is the criteria for the picture format?

for example:

  • album with a “folder.jpg” size 56 k works

  • album with a “folder.jpg” size 8k doesn’t show

Maybe Paul or Ted can answer this.

I guess no one can tell me!

After experimenting with resolution.

I tried 1280 pixel setting as picture resolution and suddenly the cover appears on my DS.

is this a coincidence?

But how can I operate the DS DAC without the physical remote control? Any app for a universal remote control with all functions?

Contact PS Audio and buy a replacement remote. It is the same one for the DAC and the BHK preamp. The Bridge can only be controlled with the app from it’s manufacturer.