DS playback issue

Trying to play Tidal masters through mcontrol on my DS with Bridge 2. I find when I try to play a master file, it stutters in playback for the first few seconds. My DS is plugged into a Google wifi point via cat5 cable. The google wifi is on a wifi mesh back to my main router. The google wifi passes the mesh test in my home and gives me circa 80-90 mb/s via wifi. I do not have any issues with any other component attached to it via wifi. If I test the cable link from the google wifi into an old laptop, I get the same performance at 80-90 mb/s. I monitored the wifi download speed for each component to try to see where the blockage was. My iphone playing tidal, playing a masters song, connected to the same google wifi point, will download at 80-90 mb/s for a few seconds before settling down (effectively it has buffered the song). The DS/Bridge 2 connected via cat5 maxes out at 2 mb/s and takes longer to buffer then the song plays fine. This is a repaired Bridge 2 (my second). It has worked fine for a few weeks. Any idea what is going on and how to solve?

First up, please take care when talking about network speeds to use exactly the same units as your measurement tool gives you, including capitalisation. Annoyingly, our technical ancestors chose to differentiate a “bit” and the eight-times-larger “byte” with nothing but lower and upper case. Bits are “b”, bytes are “B”, and there’s nearly an order of magnitude difference between them.

Mbps – million bits per second – is the unit most often used to describe a network’s maximum transmission speed. But we usually measure the size of data in bytes, so frequently when describing the real-world performance of downloading some specific item we will use MB/s – million bytes per second.

That said… if you are truly using a Category 5 UTP network cable my first suggestion would be to try a better one. At the very least get cat5e, but these days cat6 is cheap as chips. You certainly don’t need anything higher than that because the Bridge only supports “Fast Ethernet” which has a transmission rate of 100Mbps.

Sorry - it is running at 80-90 Mbps over wifi or cable to be precise. As I said in the note, it runs at the same over the cable when I test it. The cable is a cat5e.

OK, your cable is probably not the issue then. Do you have any other kind of high res files you could play locally on your network, maybe using UPNP instead of Tidal? The idea would be to rule out a network issue by proving that high speed communication is still possible.

One generic reason for poor performance on a Fast Ethernet connection is a mismatch in the duplex settings between the two devices. If one is operating in full duplex and the other in half, it gives performance similar to what you’re seeing. Unfortunately I have no idea how you could modify the manual vs auto settings for duplex on your Bridge or your Google Wifi unit – that’s something you’d need to investigate.

Other than that, I’m afraid I have no other suggestions. Good luck with it!

Bandwidth and latency are separate parameters. If it plays fine apart from initially, the suspect is latency.

An internet speed test covers both, but you can’t run it on Bridge. Try another device and see what it shows.

Internet is 80-90Mbps, ping 10ms, speed of tidal master played on iphone using wifi connection to same google wifi point uses up to 80-90Mbps. I can see the speed of the wired Bridge 2 on google wifi point settings and it maxes at 2Mbps regardless. I can test the same wire using a PC and internet speedtest and it is 80-90Mbps and a 10ms ping. So it seems the limit is the bridge. I will test something else using UPNP.

Just punting. Have you got the latest Mcontrol app?

That is true.

That is mistaken, sorry. You notice latency when something is interactive – like on a voice call or video conference, or playing a real-time multiplayer game etc. But music streaming is essentially one-way and you aren’t going to notice even a few hundred milliseconds of latency except for that tiny delay after you hit play. And honestly much of that delay is other kinds of overhead not round-trip time per se.

Some kind of bandwidth constraint is the most likely issue being encountered. It’s only the higher-bitrate Tidal Masters files that are mentioned as being a problem. I had a similar issue with Roon streaming some years back where I could stream Tidal CD quality audio just fine but no Masters without horrible skipping and pausing because I just didn’t have enough bandwidth to support playback.

Mconnect Control 2.4.54

Just set up JR and DNLA, which plays large files from my PC, via mesh wifi to google wifi then wired connection into the Bridge 2…all fine, no skipping at all. Outputting PCM 24 bit. Hmmm.

Have you got some 24/192 WAV files to play to it? Those will be the most demanding on the network.

I played the largest files I could find via JR/DNLA and no problem. It must be something to do with the Mconnect/control and/or Tidal integration. I decided (finally) to just subscribe to Roon. It works fine with the same master tracks that were causing issues the day before. So problem solved, with Roon…


Are you using mconnect control HD app? I do not use it anymore but in the past this one worked the best for Qobuz and Tidal with Bridge II in my case.

This is why I’m very glad the new Airlens is going to support Roon. I hear about and have dealt with a number of annoying issues with the stock software that I don’t want to bother with that buggy stuff anymore.

1 Like

I was using the Mconnect control app, not HD, version 2.4.54. Unless I can avoid it, I will never use anything by Mconnect again :slight_smile:

I’m very happy with the Stylus OS came with my Euphony server. It works great with QOBUZ, Todel, and music files from Interior/exterior SSD. The SQ is much better, but I think it is mainly due to the server, less to do with the OS. I do not know if Mconnect apps give worse SQ than others.