Bridge II is lost after firmware update

Hi guys,
I am normally using Mcontrol for using Bridge II.
2 days ago a pop-up appeared saying firmware update was available.
I clicked yes.
After the update, Bridge II was lost.
Then I downloaded the Windom update for Directstream Junior.
I installed it now but I see that it says “BRDG:NONE”

  • Also there is no flashing on the network cable on the rear panel.
  • Also checked the cable, it works on another device.
    Is there a way to make it return to factory defaults?
    I am located in Turley.

What can I do?

Hi @calpay2000

There are all kinds of things that you could try, but before going on a wild goose chase, I highly recommend contacting PS Audio Support ( or 1-800-PSAUDIO.

Last I heard is that their response may be delayed more than they would like but they do promise and will get back to you.

Good luck!

I did that right after writing to the forum😊
I hope they do
Thank you!

Have you shut everything down back to and including the router and brought it all back up again one piece at a time starting at the router?

One thing that scares me is, there are no lights flashing back at the rear panel when I insert the network cable.

Hi @calpay2000. Yes, please do contact us ASAP and we’d be glad to help. We’re fully staffed so response time should not be an issue. Happy to help.

Hi Paul, thank you.

I already sent an e-mail to support & service.


Does this mean that it’s still under warranty?

I can assure you the Bridge II update does work. I upgraded, and us it to JUST stream from a PC and that function is 100% OK, but a friend also updated and is using an Ethernet based streaming service, taking advantage of the firmware update just fine.


I went through the same issues with my Junior. I got it working properly by powering down with the back switch, then holding down the front power button when powering on with the rear switch. It took a few tries and it was a huge pain in the bottom, but I got there.

When I do that this menu appears and I hit ok.
Then it reboots.

But still no Bridge

Were you talking about doing “set defaults” over and over again?

Yes sir. That’s what it took for me. You might try to boot with the Ethernet cable disconnected. Then after it is up and running reconnect it.

It took days for me and then all of a sudden it just started working. Sigh.

So you also lost Bridge II as an input and all of a sudden it came back?

Ye sir. I did so many things to try and get it to see the Bridge. For a while I thought it was the Ethernet cable so i swapped it out. It drove me mad for days. I wrote tech support but I don’t recall hearing back. And then it started working.

If you really want to go mad try use the front panel interface to set a static IP address.

1 Like

LOL, I just checked and it is currently not working. Bah.

And oddly enough, now it is. I give up.

Sorry about the delay in service everybody!

If you’re still having any problems with this, email me directly at I’d be happy to figure out what direction to go from there.

Thanks and Best wishes!

ARE the Ethernet link/activity lights on/flashing on the B2?

When I first got my DSJ and performed an update the leds went out. The B2 module needed to be swapped out as the update left the B2 bricked. PSA of course helped me and resolved the issue. I had no further issues updating DSJ B2 while I had it (have DSD now).

Greetings to all.
I have the same problem with Bridge 2 and Directstream. After updating to Windom, the inscription Update Bridge appeared. Clicked refresh and the bridge disappeared.
I contacted the support service twice, and at on June 1 and 10. I was assured of a speedy consideration of my issue, but it was not resolved.
I continue to live without Bridge 2 and cry. :))))))

And yes, I tried the focus with pressing the front button and manipulating the flash memory specifically for 2 GB and the program recorded on it, which I downloaded on the PS website.
Nothing worked.

Hi guys,

Just wanted to give you an update about the case.
It seems that something was wrong about the mainboard and guys at PSAudio helped me to replace it.
Now everything’s in order and the room is full of music again.
Me being in Turkey and Covid-19 delayed the shipment a little bit but I’m happy now :slightly_smiling_face: . It’s nice to see how PSAudio stood by their product and helped me out all the way from the US to Turkey. Thanks again guys!

1 Like