file r/w error


#1

I am getting this error on my DST.

It says

“internet ok”

“sd card ok”

then displays

“downloading…”

then

“file r/w error”

any idea what’s wrong?

I noticed that when I go to the settings, it says “IP not connected” or something

Any idea what I am doing wrong?


#2

SD cards have a small slide switch on the side. When it is forward (toward the contact pins) the card is unlocked and can be written to. When slid toward the back, the card is put into read only mode and you can’t write any new data to the card. Turn off the AC power switch in the back, remove the SD card (press in and release) and make sure that the lock switch is slid forward. I have had some cards where the switch moves so easily that it has slide back when inserting the card.

After you have checked the switch, re-insert the SD card. For Direct Stream Memory Player (DMP) the contacts go face down. For the Perfect Wave Transport (PWT) the contacts go face up.


#3
DoggieHowser said

I am getting this error on my DST: “file r/w error”

I noticed that when I go to the settings, it says “IP not connected” or something

Any idea what I am doing wrong?


Doggie-

When you display the settings screen, you should see an IPv4 address on the last line of the screen - something like 10.0.0.20 or 192.0.0.30 depending on how your router assigns addresses. If there is no address, the DMP isn’t talking with your router and isn’t properly connected no matter what it claims the internet status is on the main screen.

Also, verify that the Unit ID field (the first line on the settings screen) is populated. If it is blank, your unit won’t connect to the PS Audio database. In this case, contact PS Audio support.

If there is a unit ID but no IP address, try rebooting the DMP or restarting your router or both. Additionally, verify that the ethernet cable the DMP is using isn’t faulty and is correctly plugged in. Consider swapping cables with another device that can connect. Ports also go bad - switch the cable to a different network port.

Depending on how your router is set up, you may have to access its administration console to allow your DMP to join your network.

Once you get the DMP on your network, there is more work to do:

Go here to register your DMP so the PS Audio database recognizes it.
Then go here to see your playlist. As you load discs, they should appear in your playlist. Use the playlist to edit disc data and add artwork.

Even after doing this, you still may get the “file r/w error” message. This happens all the time. It may be caused by no entry in the database, a problem in transferring that data to the DMP, a problem writing the data to the SD card, a collision of dust particles in your living room, strong winds in North Dakota, or a supernova in a distant galaxy.

When you get the “file r/w error” message, first check your playlist to verify the PS Audio server has detected you’ve loaded a disc and found the correct disc info. You may have to update the entry or add artwork. Then try stopping play, tapping the play button, tapping pause, and patiently waiting for the metadata and artwork to reload. If the disc is playing, the artwork often does not load correctly.

Sometimes the artwork will not load no matter what you do. You can try uploading a new version of the artwork to your playlist - sometimes this fixes the problem.

Good luck.

-Pb


#4

Why would it say internet ok then not have an IP address


#5

Just checked. I swapped the network cables with my Bridge 2 and the Bridge 2 still gets an IP address. So it’s not the cable or the router.

But when I press the … on the top right corner, the IP address still says Disconnected.

On the main page on the bottom, it says internet: ok and SD card: ok

When I press play, the bottom display changes to

downloading track info

then

downloading file r/w error

I’m on firmware 2.06

bootloader 1.13

fpga 1.04

Web 1.06

engine 26-1125

ip address Disconnected

ive already registered the unit on my user page


#6
DoggieHowser said

Why would it say internet ok then not have an IP address


I can replicate this on my setup. I have a wireless bridge and the DMP is connected to that bridge via an ethernet cable.

If I have the wireless bridge OFF, the main screen of the DMP only displays SD card:OK (no mention of internet at all) while the setup screen shows DISCONNECTED.

If I turn the wireless bridge ON, during the period of time that the bridge is trying to join the network I see Internet: OK and DISCONNECTED on the setup screen. During this time there is an active device attached to the DMP’s ethernet connection, but there definitely is not a network connection available.

Once the bridge has established a connection, an IP address is displayed on the DMP’s setup screen.

I think that the main screen’s Internet:OK message is only checking for an active device on the other end of the cable and not whether there is a valid internet connection.

Check you router’s settings and verify that it is not blocking your DMP from joining the network. Alternatively, try your DMP on another network, such as one at a friend’s home or borrow a different router.

-Pb


#7

I may have missed it, but if not, have you tried a different SD card? You would have to download the current Firmware, and would probably lose the CDs already on the card, or you might be able to put them in a file from the old card, and add them after the Firmware.

I have a Raspberry, and I was reading that the card can become corrupted by improper shut down. That is not what I think happened, but an example of a card going bad.

Have you called customer service? They will be able to help you, and if needed, maybe send you a new card. With the Raspberry, they also say that you may have to reformat the card. If your computer has a card reader, you may already have the software to do that. Otherwise, it is available free online.

I had to send my PWT in a while back, and I never reinstalled the Ethernet cable. I have been tempted to pull the card and delete all the CD info. I prefer the big numbers, as I can’t read the screen from where I sit, and if I have to get up anyway, it is just as easy to look at the disc case. And I always shut the display off.

If you could program tracks to play, then I might care. It’s kind of odd, my first CD player, a Sony 5 disc carrousel was fully programmable, and I think both my CAL DX-1 player, and my CAL Delta Transport were programmable. But my PS Audio Lambda wasn’t. I don’t think I can program my Oppo 83se either. I always liked that feature. If I had say 20 minutes, or a few tracks I didn’t like, I could just program what I wanted to hear.


#8

Good thinking, it is worth checking the card itself.


#9

Thanks to Elk - I swapped the cable to a different switch and it works now…

I did reformat the SD card in a proper Windows partition to see if formatting it in FAT32 on my Mac may have caused an issue. It didn’t.


#10

Yes!