PWT - when trying to install an update, the unit died

Hello All!
The over day I bought Perfect Wave Transport. The device worked well, the firmware on it was 1.23. On the psaudio site, I found that the latest firmware is 1.24 and decided to install it (Oh my God! I wish I hadn’t done this!). I did everything as stated in the “HOW TO” section. The only thing I used was a micro SD card with an adapter instead of SD, also the file system of the card was FAT DEFAULT (unfortunately, there is not a word about the file system of the SD card in the HOW TO section). The update process started and the logo in the upper left corner of the player started flashing. And this flashing lasted for about an hour! Deciding that something had gone wrong, I aborted the process by turning off the switch on the back. I removed the update card, then inserted the card that came with the player and tried to turn it on. Unfortunately, the player no longer works, only the logo in the upper left corner of the front panel is constantly on. And that’s it, nothing works anymore :(((
Next, I reformatted the card to FAT32, downloaded the update and tried to install, alas, the same behavior of the player. I tried older versions of the firmware - unsuccessfully:(((
Has anyone else had a similar issue and managed to overcome the same problem? Maybe there is an opportunity to make a recover, clear the player and download the program again?
Please help me to solve this problem if at all possible.
I would be very grateful for your help!

Unplug it from power for an hour and try again.

1 Like

Don’t panic–I am certain that this can be remedied. I managed to make my DSD DAC a brick near when I first got it seven years or so ago and I ended up sending it back to Boulder and it was brought back to life. So I can’t help getting it going but know it’s not irreversible.


Unplug it for a few minutes. Make sure there are no other cables hooked up, like I2S and try again with the correct SD card.

I sent you a PM about how to fix your issue.

I will PM you directions how to correct your problem.

Just post it here so others can remember it and be useful when it happens in the future.
Pretty please?

I don’t think PS Audio would appreciate my sharing how to create a force load card on the open forum. Anyone who needs help can always PM me.


There is no issue when using a micro SD card in an adapter. I do so all the time. I am unsure what you did that caused your issue but it is definitely recoverable.

Hello all!
Guys, thank you all so much!
Problem solved. The whole thing was all the same in my SD card (Micro SD + adapter). I tried all your advice, all with no success until I finally got an old 2GB SD card. I formatted it in FAT32, uploaded the update, installed it in the transport and voila - in less than a minute my PWT came to life! Yeeees!
Special thanks to Caleb from psaudio, I communicated with him by email and he sent me an update with a certain Bootloader. As I understand it, this is something similar to what sixpack1 advised + an additional .hex file. And yes, it only worked when using a different SD card! While I used my micro sd + adapter, nothing worked. This is strange, since computers see this card, format it, etc. but the PWT didn’t want to read it!


Glad you got it working. My force load would have done that too. I use micro sd cards in adapters without issue. Most likely the format on the card was your issue.

1 Like