Flashing the ps audio perfectwave dac mkii?

I just picked up one, used and it is currently running version 2.4.6. How old is this version? Also, when I try to flash using the SD card slot in the back (pins pointing up) nothing happens. I don’t get a click when putting the card in, Power off, wait 10 seconds, power back on in the back, initiating message comes up and back to the default screen. what am I missing? thank you and sorry for the newbie questions.

I don’t remember the exact age of that version but it is pretty old. How big is the SD card you’re using?

Hallo, the 2.4.6 is not the latest; now is avaiable the 3.0.4 version; https://www.psaudio.com/support/downloads/
but, in my case, was not working (Scott form PS Audio, very kind, said that they were fixing the update problems of the 3.0.4 version; maybe, now, they solved).

Scott suggest to use an SD card that is 8GB or smaller and to format as FAT32, uploading files one by one. In my case, it worked.

Bye :slight_smile:

It was the one file at a time thing that did it. I tried the card (4GB) and still nothing and last thing to try, one file at a time and bingo, it is flashing the unit. thank you.

1 Like

Great! Now, enjoy the music :slight_smile: :wave:

1 Like

Very odd, any explanations why one file at a time?

…unless the files weren’t unzipped and copying one at a time was forcing an unzip on the fly

I cannot explain, it doesn’t make sense to me. All I know, and maybe it was coincidence, is that I formated the 4GB card and moved all the files together to the card from an unzipped folder, tried it and nothing, I then deleted all the files and moved one by one to the card and bingo, the flash started the second I turned the unit back on. I am now running the latest version. Side note, this DAC is amazing, it replaces a Mcintosh D150. It is more details with a sound stage that completely fills the room, also amazing, well controlled bass. Couldn’t be happier.