Please help my DAC mkii can not wake and stuck in initialized

Hey dear Adminstrator.
When i tried to update firmware and fix dac can not reconize bridge 1 by sd card, the dac can not flash again the sd card (now 3.0.4 firmware in). And it stuck in initialized screen, and it can move on any more. I tried unplug and turn on many time but it didnot flash like it should. Please help me. Thank you!

Would you please help me with Disc Rescue for DAC PWD like the other product?
Thank you!

I can tell more detail. Seem like I have used a wrong firmware to update for my DAC PWD MKII (I used direct stream firmware insteal).
Please help me!!!
many thanks!

Sorry to hear about the mishap! No worries - we can fix that up no problem.

Email me: for special firmware to install 3.0.4 back on that unit.

We’ll figure out the Bridge I from there.


Thanks for reply, Tj Tomasetti.

More detail: seem like nothing happens but installing firmware of directstream. When i try some version of directstream (now is 1.1.7), the ps light blinks, but then stuck at initializing screen. But when i try pwd firmware, nothing happen, the light didnt blink.


Vào 11:04 CH, Th 2, 20 thg 1, 2020 Tj Tomasetti via PS Audio đã viết: