FW update DSJ not working


I wanted to update my DirectStream Junior to the Version 2.02 (snowmass).
I inserted a USB drive with FAT16 containing the extracted files. The DSJ is blinking a few minutes when powering up but then when I check the FW Version the main Version still remains at 1.25.

Do I need to update to an older version first before being able to update to 2.02?


I had a similar problem. Did you check if your drive is MBR formatted (mine was GPT and did not work)?

yep, It’s MBR. For the small drives, I don’t use GPT.
I also tried different USB drives from 4 to 32 Gb but none of them worked.
For some, the DSJ does not even blink when booting, for others, it blinks a while but then the FW still remains the old one. I think that it means that when blinking, it recognizes the USB FW but then in the end it does not update.

Solved it.
For the record:

->Drive must be USB thumb drive (USB disks do not seem to be recognized)
->Try many different drives. I tried 8 until I found one that works. (SAN Disk Ultrafit (nano sticks) seem to work) - If it blinks a Long time when booting, the drive is being recognized. If it directly goes to loading the FPGA, then it does not recognize the drive
->Do not open the ZIP and directly extract to USB. Save ZIP to local disk, unblock ZIP, then extract to disk formatted as FAT32 Standard sector size.

Would be good if PSA would be a bit less peculiar with USB drives…
Never had issues upding my PowerPlant with SD Cards.

glad you solved it. these usb requirements are, to say the least, idiossincratic

Thanks @ChrisTea, glad you were able to get it working.