Help me get my Bridge II working please?

Initially lost Spotify Connect facility, then the Bridge itself.
Multiple Network resets and cable changes later and now the Bridge itself isn’t showing up on the Network, so no MQA or Spotify connect on my DS Snr.

Luckily my Oppo 203 is a Roon endpoint so have my music, but no Spotify Connect or MQA from Tidal.
Any help getting me back on track appreciated, thanks.

Some troubleshooting info:
Network structure is as follows:
Cable Model > Router > DS with Bridge
On the DS home screen when Bridge II is selected, the network icon shows Green not red.

The Ethernet connection I use to the bridge passes network access to any other device I connect it to, so it works ok.

Screenshots form my DS/Bridge

On my Router admin screen, the DS doesn’t show up as a connected device, which explains why its not showing up in Roon.

Can’t upgrade the Bridge firmware in MConnect as its not seen to be on the network there either.

Any help to get my Bridge working on the network again much appreciated, thanks. :slight_smile:

If you have not tried this, in this order – this is the “rain dance” I perform when I can’t get the network to complete its “handshake” with the Bridge on occasion (worth a shot):

  1. Power down (hard off/no standby modes) all individual pieces and parts of kit making up your network, including the DS and leave everything off for at least two minutes. (I prefer to actually unplug all of the kit.)

  2. Starting upstream of the DAC (e.g., with your modem or modem/router), power everything back up one at a time. The DS should be the last piece of kit you power back up. [Don’t forget to remove the SD card before powering the DAC back up if you are using the latest version of Snowmass. Otherwise, the firmware will reboot as well. I try not to reboot the firmware when power is lost to avoid the outside chance of an overwrite corrupting the code or partial reboot.]

  3. Wait at least five minutes to see if this did the trick. If not, add one more step – from the DS set up screen, press the bridge reset button.

This works for me. Patience is key. By the way, sometimes all you need to is that last step (bridge reset button).

Hope you get it sorted, soon. I know this is very frustrating when it happens.



PSA customer service is generally pretty responsive. Give them a call on Monday if need be and one of their representatives will work with you to troubleshoot this. I would not rely on their necessarily noting your post here in a timely manner.


1 Like

Enabling DHCP on the Bridge display could do the trick…

1 Like

Right - the display is showing a LAN address, but no Internet gateway or external DNS.
Enable DHCP and power-cycle the DSD.

If that should fail, you might need to also enable DHCP on the router.

Can you manually set the gateway to and DNS to

And if Gateway = doesn’t work, try

Howdy @gazjam,

There’s a lot of great advice in this thread so far. If time and patience permits, I would recommend going through the steps outlined.

Otherwise, please do give us a call - our support team would be happy to help you through things - 720-402-8946. Or you can email them directly at

Based on the information on the DS Screen this will not work. 192.168.1.x is a completely different network than what he is using.

Right you are.
(some routers default to, but not this one)
However, since gazjam doesn’t seem to be participating in the thread, it may not matter.

1 Like

Thanks Guys, maybe a little slow to get back…?
I’m based in the UK and time restricted with work, family etc.

SO what I’ve tried and what doesn’t work so far:

1 Did the “Rain Dance” :slight_smile: and no joy.
I’d did a few network resets, but haven;t let the kit power off for a period of time, will try that next.
Thanks Scottie1

Enabling DHCP and power recylce…no dice unfortunately.
DHCP was already enabled on my router.

Not tried manually setting the DNS to…what does this do?

1 Like

I’m sure they are sorry to have awoken you. :slight_smile:

Well, it has been raining a lot here in East Tennessee. So, there is that.

Good luck.


It allows the DS to connect to the Internet. At the moment, your DSD is trying to use the Router to translate URLs to IP addresses, and perhaps your router doesn’t do that?
What router are you using?