Spotify won't connect to my DSD Bridge II

Long story short, I was having issues with my DSJ connecting to Roon and Spotify, so I traded it in and upgraded to the DSD. After setting up the DSD yesterday I was able to get Roon working once i manually entered IP info in the DSD (DHCP enabled did not work). Next i try spotify and I can see the Bridge II. When i try to connect it says “connecting” but never actually connects.

I have tried the following but neither did anything:

  • Power Cycle DSD
  • Power Cycle Modem, Router, DSD in that order

Other info:
Windom 4.0.1
Bridge 3.6.8.6
DSD is connected to my network via ethernet cable to the wireless router

Any clue what I should try next?

Where is your Roon core located? That device should be powered up last. It probably should have a wired connection especially if the music is stored there. Personally I would always use DHCP but others use manual addressing with good results.

1 Like

Surprised Roon is working well but Spotify isn’t. Are you trying to toggle back and forth between the two? Roon tends to take priority, so it probably wouldn’t allow Spotify to push it to the side. You may need to completely shut Roon down in order for the Bridge to connect with Spotify.

Roon core is located on my PC which is in the room adjacent to the living room with my stereo. It connects via wifi to my router, which is connected to to my DSD. This setup worked great with my DSJ for over a year. Why that stopped working and why the DSD is having a different, but similar issue is strange.

Hi James,

For over a year I was able to push roon or spotify aside with the DSJ. I just tried shutting off Roon and connecting spotify and no go.

I took some images that might be of help. Note that the Bridge input screen shows what I last played on Roon, even if Roon is shut down.

This text will be hidden

Wild guess here, but is there any chance that the Spotify app remembered the old Bridge and is trying to connect to that? Similar to a remembered bluetooth device on your phone?

Hmm that is an interesting thought. Maybe I should uninstall spotify and re-install it and see what happens.

Thanks!

Also try plugging a network cable into the PC that has the Roon core. It cant hurt.

Hi Baldy,

I don’t have a network cable long enough at the moment. But I’m not having any issues with Roon. Why do you think this is important?

I tried re-installing the Spotify app and the same result. I can see the Bridge II as an option, but it just hangs on “Connecting” and never connects.

I don’t know why this would change anything but have you tried using Spotify through the MControl app?

I have never used MControl before. Is there a guide to setting that up?

TJ suggested i enter a value in the DNS IP setting. Right now i have it as 0.0.0.0. He recommended changing it to 8.8.8.8. Im going to try that as well tonight.

Awesome. I didn’t think about that. Keep us posted.

Couple updates.

Changing the DNS IP manually didn’t do anything. In fact it reverts to 0.0.0.0 on it’s own after I reset the unit.

Tried the MConnect control app. It sees my Bridge II, but when I select Spotify as the music library it just directs me straight to the spotify app. So no change here.

While doing all this I notice that sometimes my optical input sets the volume to 25 or 50. How do I keep every input at 100 by default?

TJ let me know that you two are working pretty closely. He’ll be your guy to work you through this weird one.

In order to keep the volume set to 100, go into the settings and set the volume to fixed at 100.

I find this kind of stuff difficult because there are so many variables. I did seem to have success with a similar problem by letting the DS use DHCP but setting the IP address manually at the router instead. It many not work for you, but it’s easy to try. Might take some rebooting all around after you set it.

Hi All,

Thanks for all the input and help. I wanted to give an update and provide some closure to this thread. TJ suggested i change the Primary DNS setting on the DSD to 208.67.222.222 and voila! Spotify connect is now working! I am happy camper now. :smile:

Shahram

Dang computers anyway. . . . . . .