Help with P20

#1

Hello. My P20 arrived this evening. I am using the power cable that came with it to power the P20. I have my various gear plugged into it. The P20 powers up, initializes and then all the outlets turn green. Except no power is coming out of any of the outlets. I touch the outlets on the screen to turn them red, then green. But still no power comes out of the outlets on the P20.
I have looked at the manual for the secret clue as to how to get power out of it and I find no answer. Do any of you know what I am doing wrong?
I just want it to allow my gear to power up.
I am not interested in cable discussions. I already tried a very expensive 20amp cable before I tried the supplied 15 amp cable.
The screen lights up, it acts like it is fine, except it does not pass power.
Help please, tech support is gone for the day.

#2
  1. Connect the P20 to your network to access the web pages.

  2. Go to the configuration tab.

  3. For each outlet change Delay Mode to “always on”

  4. Then “save” configuration (at the bottom of the page).

See if that works.

#3

Thanks, I had already done that via the front panel, but now I have done it via the web interface as well. No luck. Sigh.

#4

Well, looks like you might have joined the P20 DOA Club. You aren’t the only member in the Club. You will need to call PS Audio tomorrow to discuss what happens next.

#5

This reveals a weak design point for the P20. I would have thought there would be a disagreement logic build into the outlet status indications. It seems you get an outlet “green” indication simply based on switch position. There should be a feedback loop that 2 conditions must be met for the outlet indicator to turn green. 1. the switch is in the ON position, and 2. Power is actually sensed at an outlet and found to be within tolerance. If there is a disagreement between switch position and outlet voltage being detected within limits, then there should be a fault warning given (eg amber indication for affected outlet).

The P20 should be smarter to self-diagnose this problem and tell you about it.

#6

Another P20 DOA, what did the status screen show for you? What are the input and output readings?

#7

The input and output readings show dirty power in, clean power out. But the load is zero because no power is being provided to the outputs.
It’s like there are relays that aren’t doing the job of switching on the power.

#8

Maybe you can try to update the firmware to see if that’ll help.

#9

Did that, did not help.

#10

On my P15 I hear relays click when power cycling the outlets, do you hear any relay clicking? Looks like your relays are not working properly, or the control board is shot.

#11

As I stated in a message above, it looks like the relays are not doing the job.
I have powered up and down, switched on and off, updated firmware.
Nothing sends power to the outputs.
I have tried all things plugged in, no things plugged in, one thing plugged in, 20 amp power cable, 15 amp power cable. checked the fuse but you know that works if the device powers up.
What am I missing?

#12

I don’t think you’re missing anything… Sorry for the bad luck. Got to wait for PSA to help you out now.

Edit, maybe mess with the multiwave and regulation settings as a hail Mary?

#13

So I had that happen with one bank of my P20. I left the P20 on and was just using the 4 other banks worked and I was waiting for the weekend to be over to get a hold of support. I left the broken one green. One morning I accidentally double tapped the screen on the broken outlet quickly and I heard a double click and the outlet started working.

Now all this could be random coincidence, but it worked from there on. This probably doesn’t help at all, but maybe worth a shot while you wait to call support.

1 Like
#14

It was worth a shot. But nope, still bah.
I’ll call tech support in the morning.

#15

Sorry aangen, they will fix you up

1 Like
#16

Just saw this. I am so sorry. This is the second instance of a P20 with no output that I have heard of.

I am just getting back from the AXPONA show and don’t yet know what’s happening. I will have customer service get you a replacement ASAP and will have engineering figure out what’s up.

It sounds like it is software related. If it is we can maybe fix it with code. If not, we’ll replace it immediately.

1 Like
#17

Paul, more interesting is how did this unit leave the factory in the first place? It unlikely due to shipping, especially if this is software related issue.

Good luck with the troubleshooting

1 Like
#18

I can assure you it worked perfectly before leaving the factory. If you ever have the opportunity to visit with us you will see the extensive testing and burn in process that we go through for every unit.

So, what we know is that it unquestionably worked before leaving here, which would pretty much rule out software unless there’s something funny going on at the customer’s house the software isn’t happy with.

One other possibility that comes to mind is that perhaps we mistakenly sent out a 230V export unit. There would be enough voltage to power the microprocessors to run the display but not enough juice to power on the relays.

I am just guessing here. If it were the latter there’s no danger to the customer other than the hassle it doesn’t work.

We will get to the bottom of it.

1 Like
#19

I appreciate the help. I can’t wait to finally hear the results of adding this to my system.

#20

We just emailed you for your serial number.