Invalid token

I’m unable to use Tidal with mconnect, I get a invalid token message.
Tried reinstalling the app with same result, have not found any fix on line. Waiting to hear from Tidal and Converse Digital. I use the app with iPad and iPhone. Qubuz and everting else works okay. Any insight greatly appreciated. Thank you

I was having that issue a while back. I think I was signed in too many times or in too many locations. I think that’s what fixed it for me.


I am getting the same problem. Please help

yup same issues here, updated both tidal and M control app and still says ‘Notice Invalid token’

yup-I am having that issue now too…Been rebooting, signing in, signing out, changed passwords… nothing helping thus far-playing through Muzo

I have the same problem, my “mconnect control hd”, black, in my iPhone and Ipad, after a today´s update,
does not work, says “Invalid Token”. Please, help!
Thank You.

I’ve asked our engineering director to have a look.


Just wondering if anybody else is having a similar problem. When I use mconnect control to stream tidal on DSD with Bridge II, I get invalid token. I try to log in and says invalid token. This is true for both android and IOS versions of mconnect.
Streaming tidal using BubbleUPnP works fine, but no MQA decoding of course.

Any help would be appreciated.


I also have this problem. It appears to be a problem with the mconnect app. I sent a few emails to the app people and they replied that they were aware of the problem and they were working on a solution. As of now 1:35 AM the problem remains.

I have seen a few queries like this, I wonder if it is connected to this incoming internet debacle:

worse for embedded gadgets that don’t have active updates available, but as the article points out, these kind of failures often give no meaningful error message.

n.b. this may well be a red herring and a complete distraction.

Yup, definitely an issue. Luckily my Lumin app with BubbleUPNP server on my PC still runs the Tidal interface.

Looks like the problem is the same one Oppo had with Tidal. It turned out to be a Tidal back end problem. Hopefully, as in the case of the Oppo app, it’ll just resolve itself shortly.

1 Like

In the Tidal´s site, in the list of “supported devices” there are a lot of devices, but, unfortunately, the devices of PSaudio aren´t in that list.

Thank you Paul.

I was replying to Tidals message in reference to this issue and tried to login everything is back to normal. I did not have to do anything seems that Tidal resolved it at their end. So yours may be working also.
I bet it was Paul’s influence that did it… :blush:

1 Like

Hah! I am sure not, but you never know. Thanks for the heads up.

1 Like

Like a legion of other legacy users, I was happy when Oppo seemed to fix the problem with Tidal in late May. Surprisingly, new songs released since ~ 2018 still aren’t accessible; no problems with older ones. It doesn’t matter whether I ‘favorited’ them before the problem or after. Of course the newer material is accessible via the Tidal app running on phone or laptop, only. (I have the most recent firmware and media control app versions, which are ancient at this point.) Any ideas are welcome from the forum.

My system uses Tidal streaming via Oppo Media Control on an Android tablet to Oppo BDP 105D to GCD to Stellar M700 to Magnepan 1.7i.

The problem is a bit more chaotic than I indicated, with random older also recordings seemingly inaccessible. I’m guessing that expiring rights may be an issue, and that Oppo lacks the motivation to patch this legacy product. Frustrating, may need to upgrade to a dedicated streamer.