M1200 won't boot

Today I turned on my system (all electronics are PSAudio) and one of my M1200 amps won’t come on: the front panel blue light blinks normally as it warms up. But then it blinks faster for a few seconds, and then it turns off. By the way, the amp is quite cool. My other M1200 turns on normally. I tried shutting everything down for a few minutes and restarting, but this didn’t help. Any suggestions appreciated, I think my next step will be to call PSAudio.

Did you check if the tube needs replacement?


I am going to guess that this light sequence is on purpose and is indicating an issue. My first guess would be tube as well.


No, I thought of it but the amp has been sounding great, no pops or other noises. Is there a way to check other than simply replacing the tube?
Thank you!

Looks as if I’ll be replacing the tube either tonight or tomorrow. Thanks very much!

1 Like

Just use the tube from the other amp that works to check. You do not have to get a new tube if you don’t have a spare.


Make sure your M1200 has been unplugged for enough time to dissipate any voltage before you open up the tube area.

Also, remember to rock the tube back and forth to loosen it for removal.

Beautiful hint!


Will do, thanks!


M1200 problem resolved
One of my M1200 amps had entered “fault protect mode.” Adhering to the manual advise about disconnecting all inputs and outputs, and then rebooting didn’t fix the problem. So I replaced the tube and tried to power up again with all inputs and outputs still disconnected: didn’t work. I phoned PSAudio and was advised to reconnect all inputs and outputs and try again: it worked! I’m not sure if it was indeed a bad tube, but since I replaced the tube on the malfunctioning M1200, I’ll replace the tube on it’s twin also.
Many thanks to all of you who responded. I hope everyone has a great day! (I’m currently listening to Girl of Mine by JJ Cale. There is magic in this track but I can’t tell you what it is.)


Yes. You should always replace tubes in pairs.

Thanks, you’re right. BTW the problem returned & I got an RMA to return the unit for repair.