MConnect Control App for Android Constantly Crashes with Tidal


#1

This is absolutely ridiculous. I’ve been a Tidal subscriber for several years now, and I’ve never encountered anything as annoying as this (granted, it’s MConnect - whoever the heck that is - fault).

Basically I have quite a long track list that I’ve accumulated over the years. Of course I also have several other playlists, but think of this as a 200 song playlist.

The problem exists on every Android device I’ve ever installed MConnect on, and I had previously just given up, bit the bullet and subscribed to Roon as well. I want to add that this also is a borderline ridiculous in that it’s the only means of playing a Tidal subscription (and MQA) to the DSD in a SINGLE room, especially given the yearly or annual cost. Nothing taken away from Roon - those guys are dedicated and constantly working to improve their product. But it’s silly to think that if one is to make the most of an already expensive DAC (including PS Audio products) one must factor in another $500 (or $200/year) cost on top of it. BUT…I digress.

My Roon core PC crashed and in the mean time I’ve been relegated to using MConnect Control for my downstairs system. As mentioned I’ve previously tried their app on a Huawei tablet, a Samsung Galaxy Note 5, and now a Galaxy S8+. What happens is that EVERY TIME I scroll past about 1/3 of the way in my long playlist (favorite tracks), no matter how it’s sorted in the MConnect interface, the app just crashes with some generic message popup (i.e. no useful information provided). I’ve been sending MConnect (or whoever does that app) reports with system logs via the Android crash reporter, but no idea if anyone is even receiving them.

Has anyone else experienced this? I believe that otherwise all my configs are “correct” and I was using Roon with no hiccups until the PC crashed. Of course the plan for now is to replace that laptop and continue using Roon (as they have great extras) but until then, I feel cheated that buggy-as-hell and unreliable MConnect Control is the only available mechanism by which I can play Tidal’s MQA tracks to my DSD DAC.

Also, this is Conversdigital’s “support” page: http://www.conversdigital.com/boad/bd_news/2/egolist.php?bd=2

WTF?

Ugh…


#2

Not sure what the error message reads, but next time it crashes, jot down the error code (if there is one) and “Google” that code, or message, to see if there is other reported problems and hopefully a solution. I often do this anytime I encounter a crash or error message that otherwise is cryptic. It has led to solutions over 50% of the time.

I assume it only crashes during the scrolling of the Playlist?


#3

Ha ha, yeah I’m an old hand at Google based troubleshooting. There literally is zero usable information provided by MConnect’s app when it crashes. Here it is, verbatim:

"mcontrol has stopped.

(refresh icon) - open app again
(quote icon) - send feedback"

Yep. Only crashes during scrolling, so far anyway.

And…as I suspected, absolutely useless information even to Google:

https://www.google.com/search?q="mcontrol+has+stopped"&oq="mcontrol+has+stopped"&aqs=chrome..69i57.10119j0j4&sourceid=chrome&ie=UTF-8


#4

LOL. Wow, you were spot on when you described that error message as useless.

What version of Mconnect Control are you using for Android. I just went to “My Favorites” in Tidal (via Mconnect) and it does not crass as I scroll. However, I have lots of “Albums” to scroll but not pages of “Playlists” so not sure if the crash is specific to Playlists within Favorites or any category of lists under Favorites.

Do you have pages of Albums, Tracks, or Artists under Favorites that also cause the crashing, or is the issue exclusive to Playlists?


#5

Hmm…it’s the latest version for sure because I just downloaded it again today for both the tablet and the Galaxy S8+.

But you’re definitely onto something as it only happens when I’m scrolling through my “Favorites” - Tracks (not albums or what have you), so it’s a VERY long list (like 200) songs. The strange thing is that it crashes well before I make it halfway through. It kind of reminds me of web pages that get slower and slower as you scroll down and more content is loaded (usually graphics). That’s not to say it slows down, but it does crash after having to load at least 50 or so albums. And…so far ONLY in that one list.

Thing is, that’s the way I’ve become accustomed to using Tidal over the last 3 years - primarily on my phone and on my office PC. It’s never crashed, and I think that MConnect must be getting overwhelmed by the length of the list. Guess I’ll need to start organizing better.


#6

Are you using Mconnect or Mconnect HD? Might be worth downloading the other app, not currently used, to see if it makes a difference on your tablet.


#7

I have tried both actually. Prior to getting Roon, I used MConnect HD after experiencing the issue with stanard MConnect. I think the only difference is in the way the app renders graphically, but I could be wrong. Either way, same issue with HD version, but I’ll try it again now that you mention it.

Incidentally MConnect Control has a 4.2-star rating in the Play Store, while HD has only like a 3.2. Not exactly confidence inspiring. :slight_smile:


#8

Also, FYI, I looked for MConnect Control HD using my Android phone and no dice. However, logging in the the Play Store using my tablet, it’s right there. Very strange.


#9

Try BubbleUPnP Android only… I have had nothing but trouble with MConnect since the last update as well. Bubble seems to be ok… So far anyway… Also Make sure that the DAC is set to DHCP and make sure the MConnect is also set up with DHCP. I have been told that this could be the issue.


#10

OK, is there a specific search I should do in the Play Store? When I search “bubblupnp” I get several options. Which one works best with Tidal and the DSD?


#11

I use the yellow one with the Wi-Fi(ish) circles to the right… I paid the $4.69 for the license. So you can play more than 30 mins The free version is restricted, but you can test it without paying. BTW, I uninstalled MConnect from my ipad, rebooted the DSJ (AGAIN) and reinstalled and set up Mconnect. It actually worked this morning. No guarantee it will work next time… When it fails, I fall back to Bubble. PIA that we have to go through this…