mConnectHD no longer sees Bridge II

So as I get parts of my system up and running in my new house, I come to find that mConnectHD no longer shows my DS/BII as an available device. The Bridge II is successfully connected to the network, as I am literally now steaming TuneIn radio to it from my LMS Server (on my laptop). But from my iPad - which worked perfectly before I got here, I can no longer see the DS from mConnect. Can’t seem to figure this out. :thinking:

Is this the app you’re using?

Well, I’m on an iPad go I’m not sure if what’s on Google Play is exactly the same. I’m using this

The app name is ‘mcontrolHD’.

That looks like the right one. I would try uninstalling it and then installing it again.

Mmmmm… okaaayyyy… :thinking: Weird that everything worked perfectly back at my old house.


Are the iPad and the Bridge on the same network? Even if it says they are you might try re-setting the network connections on the iPad for the new house and network. See if the iPad sees the Bridge then.

My Bridge is running on wired Ethernet, iPad of course wireless, just like in NJ. Hmm, I wonder…

At my old house I had a combined wireless cable modem, but my Bridge II went to a local switch that then went to a router port on the cable modem. In the new house I have a separate cable modem, router, and wireless AP. The router is connected to the cable modem, as is the wireless AP. The switch (same one I used in Jersey) the Bridge goes into is plugged into an intermediate switch between this one and the router. Let me try something…

Nope, that didn’t work. I bypassed the intermediate switch and ran the audio room switch directly into the router. Still can’t see it from the iPad. :worried: That’s the closest setup I can make to my old configuration.

There is a good possibility that doing both what James and I suggested will clear the problem as either Mconnect or the iPad are looking for the IP address from the old house and ISP. Clearing the network settings on the iPad and installing a clean copy of Mconnect HD will give things a fresh start. When I took an iPad and an Aries G1 from the Florida house to the SC house I wiped the settings out from Florida and started over to avoid any frustration.

I just deleted the app and reinstalled. No go. Clear my old network settings from my iPad? How would I do that? I can see that it is using my current wireless network (which has a different SSID than my old one).

Under General go to Reset and then Reset Network. After that is done and you’ve chosen and connected to your new wireless network then shutdown the iPad and the DS and wait a few minutes. Reboot the DS and after it shows the Bridge has a signal then start up the iPad again. Then check inside Mconnect and make sure they see each other.

I followed your instructions, but still no success. I thought back to how I set up the network last year, and then it hit me - I have the WAP on its own subnet, partly for isolation but mostly to keep all the broadcasting off my wired network (which serves my audio system). I never finished setting up the router so that the two could see each other. Or rather, I was in the process of trying to figure out how to get them to see each other while keeping all of the wireless broadcasting off the cabled network. Wasn’t sure of the best way to do that. I guess I’ll have to finish that investigation.

The problem of hopping back and forth over the past year between two houses. Apparently I was using only half an arse on each! :roll_eyes: :rofl:

You could try the lumin app. In the past, I was able to use it to stream to the bridge ii.

I think until I get one subnet to see the other one, this isn’t going to work.

I just setup a newly purchased DS DAC with a Bridge ii, one issue I encountered was that newer releases of iOS block local network access by default. Go check under settings, find the MConnect Control app, there’s a toggle to enable “Local Network”. If that’s not enabled you will never find the DS on your local network. You may have a different issue but thought I would share in case it helps.

Edit: I did some testing and if I put the DS on a seperate subnet, I cannot access it from the Mconnect Control app. I have reachability between my two subnets, yet still cannot get the app to discover the bridge ii. The bridge ii may simply not allow access to a different subnet. That’s most likley your issue.

Welcome Soriorda! Thanks a bunch, this is very valuable info!

Hi @soriorda
Following on your edit:
Your iPad and Bridge must be on the same LAN under the the same DHCP controller. If you are using range extenders, for your sub LAN, make sure you are allowing your DHCP controller to manage all IP addresses (usually the main router) Also, I would try giving Bridge a fixed IP address. This ensures no IP address conflicts are there.

Hi @Serhan. This is what I’m trying to resolve as per my implication posted just before @soriorda ’s post. I was going to just set up a secondary wireless LAN in my UniFi nano HD (it’s capable of supporting up to 4), but I think I like your approach better. My DHCP controller is my Edgerouter 4. I’m going to try and figure out how to get it to do what you’re saying. IIUC, though, if I do that, I should probably turn off DHCP from within my UniFi. I was allowing it to serve IP addresses to all of the wireless devices on my wireless LAN.

1 Like

Hopefully all would go smoothly.

I also use Ubiquiti gear. I have an edgerouter 3 and UniFi cloud key gen2 running my WiFi controller for several APs in my house. There’s lots of different ways you can ensure the bridge ii and your iPad recieve an IP address from the same subnet / DHCP server. I believe one method would be to just setup the unify controller to use DCHP relay mode to your Edgerouter 4’s IP address. The access points would then just forward the DCHP requests to your Edgerouter. I highlighted the option in my controller, however yours may look different depending on which version you are running.

Thanks @soriorda. I’ll check this. Do you have your wired and wireless LANs on different subnets?