MkII trying to do room correction with Focus Fidelity

I have been successful in getting the MKII and mic on my new Laptop up and running. The computer sounds and even youtube work via the MKII. But when I open and set up Focus Fidelity Impala measuring software it does not see the MKII. its the default audio device in windows. everything else sees it. Am I missing a setting? So close to doing my room tune but cannot get by this. Will have to call tomorrow.

@tedsmith i think we have a similar issue with these guys on the new USB module you talked about. Input in DDC and it now works. Their software does. Not see the DAC.

I went trough tune with focus fidelity with DDC. On sweeps it gave some timing error. I could not get past. I hit ok and moved on with all 6 sweeps. Yuch tune lost all soundstage. I need @tedsmith to let me know what’s new with dac usb input so I can communicate with software vendor.

The DS Mk II uses a different USB chip than the DS. It’s a ComTrue chip instead of an XMOS chip. Tho USB lets you query for the device capabilities (e.g. supported sample rates, sample widths, …) some programs seem to use a table of supported USB devices instead of querying the USB device and the Mk II isn’t in their tables.


Thanks Ted I asked them that. And they replied:

"Impala uses the windows audio programming interface and queries the USB audio devices through that, it doesn’t store a table of supported devices.

As I mentioned it does require that the device and its driver support event driven mode.

If it doesn’t support event driven mode then Impala can also use the ASIO professional audio interface, can you ask PS Audio if they have an ASIO driver for the DS Mk II?

I haven’t heard of the ComTrue interface before, the XMOS ones always worked really well with the correct driver installed."

Does that make sense to you?

PS Audio does support an ASIO driver, it’s installed as a part of the USB driver package.


any idea what event driven mode is?

USB WASAPI drivers can operate in the old “push” mode or the newer “event” mode. Some WASAPI drivers only work well with “push” mode and others with “event” mode.

ASIO is a different kind of driver all together - if it works it’s probably the preferred USB driver - with it you don’t have to worry about setting up things like Window’s “exclusive” mode or that the Windows volume control and mixer will corrupt your audio, etc.


Which way do the PSAudio drivers work? Push or Event?

They are suggesting a spdif converter

Douk Audio U2 XMOS XU208 Digital Interface, USB to TOSLINK Coaxial/Optical Audio Adapter, for DAC/Preamp/Amplifier, Support PCM & DSD64

You’ll have to ask PS Audio support about specific USB questions.

Since they support ASIO and PS Audio supports ASIO I suggest you at least try ASIO. Then “event” vs. “push” doesn’t matter.

If a maximum sample rate of 192k and a maximum DSD rate of DSD64 is acceptable then a USB to TOSLink, S/PDIF and/or AES3 converter is an easy way to not use the Mk II’s USB input.


I tried the ASIO driver and it does not recognize the MKII. :unamused:

Did you power cycle the MKII after you selected ASIO?

I did not. Should that matter? That driver the web says it’s not for this dac. The driver itself would not install due to it could not find the dac. USB was plugged right into app.

Still working on getting this work with DDC in the middle. Some timing issues. Could be my 20’ cable is too long for the USB transmission.

Either way @Paul there is def. something up with the usb driver that this piece of software cannot lock in on it. Not sure if that something your team could help with? I know I am not the only one to use it. The USB driver works with windows, but not the query from this software does not find it. Either they need to change how they look due to not being XMOS (@tedsmith correct me if that is not the right thing to say) or its not being exposed properly somehow.

20’ is way too long for USB, the limit is 15’ between devices and/or devices and hubs. If you are using an “audiophile” USB cable, as an experiment please try a cheapo USB certified cable. If it works then the audiophile cable is likely out of spec. 20’ is out of spec unless it had an active repeater somewhere in the middle. The problem with non-certified USB cables is that they can work one day and not the next, they can work with some hubs but not others, they can work with some USB drivers and not others, they can work with some OS’s but not others… With cables that are too long I’ve even had them work until the tempurature changes a little. The 15’ length and the cable inductance and capacitance affect the time it takes for a signal to propagate. If the cable is too long, is out of inductance and capacitance spec, etc. the signal might not get to the hub or device and back in time causing errors.

The USB chip and code in the Mk II doesn’t know what’s trying to talk to it and acts the same either way. It certainly is possible that some assumption is being made by accident about what the Mk II can or can’t do.


Good to know. I have some shorter ones. vanilla cables. For this effort that is fine.

Have you seen anything like this?

WEme USB 2.0 Extender to RJ45 Over Cat5E,6,7 Connection up to 100 Meter 328 Ft Ethernet Extention Cable Type A Male to A Female with 5V2A Power Adapter

These kind of extenders get around the time limit by pretending to be two or three hubs in a row, that gives them two or three 15’ times and also the spec’ed time thru a hub to get thru their electronics and their cable. I haven’t seen anything this cheap before that supported USB 2.0 High speed and did isochronous transfers. But this listing explicitly states that it supports cameras so it has a chance of working for audio.


Thanks for the tips. I went with cheapo wires I had hanging around. It worked. But still only via stage Matrix DDC. USB directly to the MKII still did not recognize.

Just in case I’m missing something: When you say “USB directly to the MKII still did not recognize.”, USB directly from what? A PC running Windows or another piece of hardware?