Need Help Installing the Network Bridge


#1

I installed the Cat 6a cable to my router but I seem to have misplaced the instructions for connecting to the PS Audio server. The Quickstart guide stops at the point where the ethernet cable is connected. What I need are the next steps…

Can anyone help me find the steps to connect to the PS Audio server and get Tidal up and running?

Thanks.


#2

Well more frustration. I found some posts about using MConnect Control to play Tidal and Qobuz but when I select Bridge II, it says neither “is supported on this device”.

Does anyone have the Bridge II instruction sheets? I cannot find them on this website.


#3

One tip: make sure you downloaded the mcontrol application on your mobile device. mconnectControl is the app. you want to be running. I believe the current version is 2.4.10. Good luck.

PS

There is support on the developer’s (CONVERSEDIGITAL) site at converse digital.com.


#4

Your reply is confusing. You say don’t download the Control version but then you say Control is the app I want to be running. Which is it? I tried the Control app. Doesn’t work.


#5

Think you need the latest Bridge software installed too. Don’t recall which version unlocked Tidal in mconnect (don’t use it).


#6

Yes, it was. You are looking for this, I believe:

mcontrol app

Sorry about that… Will edit my original post…


#7

I have the latest Bridge II software installed.


#8

I think I downloaded MControl HD. Maybe that is the issue.


#9

Nope. Still getting this error message:

“Selected device does not support TIDAL.”

Isn’t there a setup procedure for connecting to my router? Don’t I have to “point” it to a server somewhere? Isn’t that how the Bridge brings in the album art?

Why isn’t there a page on this site with instructions? I did not see it in the How To section.


#10

That should work also, according to their web site: mcontrol HD

See the example screen shots.

Are you signed into Tidal on your computer/main device?

Scott


#11

When I select Tidal in mconnect or mcontrol, it goes right to a sign in screen with two fields for username and password. I don’t have a Tidal account so can’t try logging in. I assume it’ll work. I’m using JRiver as a server but don’t think that matters for Tidal Access. Make sure BridgeII is selected as the player…shows up top center of the screen.


#12

PS, make sure your DAC indicates that Bridge II is connected to the internet. Beyond that, I am at a bit of a loss. When you go to the Browser screen on the app. it should show you all of the available “Libraries” (e.g., Tidal, Qobuz, Spotify, Deezer, etc.).


#13

It’s showing the music apps. Just not letting me sign in.


#14

If all else fails, my default is to start over. Have you tried re-booting the network and the DAC?

Once you have reestablished your network connection with the Bridge II, give it another go.

Wish I could be of further assistance…

If this does not work, PS Audio is pretty good about troubleshooting with you – event if the issue is not specifically related to the DAC/Bridge. But, you are out of luck until Monday.

Hang in there.


#15

Thanks for your help Scott. Another friend is going to help me today as well.


#16

Do you have this?


#17

I do not. Thanks for attaching. I will see if this solves it.


#18

Still no luck on this. Anyone have any other ideas? Is there an initial setup to connect with the home network or is that automatic when I plug the Cat 6a into the router?

Has anyone done this who does not use a NAS?

Thanks in advance.


#19

When you use the front panel options does the Bridge have an IP address? If so, if you have a computer hooked up to the network, I would suggest installing a trial copy of Roon, then see if Roon sees the Bridge. This is the simplest way, set-up wise, to see if the Bridge is good to go.


#20

Now this is maybe the best idea so far. I do have an IP address and I have a Roon license so I could add the DS as a device and try that.