Power Play still available?


#1

I’ve noticed that PS GlobalNet no longer accepts my password. Is this service discontinued? If not, is there a way to reset the password?


#2

The service is definitely still available, but we are making some much needed changes to make the login more secure.

Implementing a password reset feature is at the top of the to-do list – I’ll be back in touch soon!

Thanks for your patience,

Tyera


#3

Hello, @jhnh

You can test the password reset tool here: http://powerplay.psaudio.com/forgotpassword.php

Let me know if you run into any problems.

Thank you!
-Tyera


#4

Thanks!!


#5

I got my brand new P5 Powerplant last night and hooked it up. I tried to register an account on PowerPlay but after I fill in my information and hit “register”, nothing happens. No error message, no loading wheel, nothing. I’ve tried two different computers, two browsers, and my iPhone. Can you help me out? @teulberg


#6

Hi @blang,

I’m happy to help! I’m one of the customer service associates here. Do want to email me the Unit I.D. for the P5?

Go ahead and send it to jamesh@psaudio.com and i’ll see if I can dig in and get it registered for you.


#7

In the absence of finding somewhere else more suitable to post this question…

Have the PowerPlay performance charts been given a work-over recently?

Mine looks like this…I’ve never seen the bar graph data presented like that before.

Screen-Shot-2017-08-01-at-9.32.10-PM.png


#8

They have!


#9

After seeing brodricj’s post, I got curious about the usage of my P5 – I’ve never looked at the graphs before. I logged into PowerPlay, my unit is recognized with its unit ID and web addresses correct, and shown as “device online” but the graphs are totally blank as far back as I looked (four months). I leave the P5 turned on all the time, and my Internet is always available. What am I doing wrong?


#10

Hi, @magister

You should see your data now!

In the course of our PowerPlay improvements, we made some changes to the way data is stored. I won’t bore you with the whys and wherefores, but in sum, your P5 performance data still needed to be hooked into the new schema.

It should be good to go going forward!

Thanks for your patience,

Tyera


#11

Thanks! @teulberg


#12

Thanks, Tyera – it’s visible now!


#13

Neat graph. I just reviewed my data and it is a hoot.


#14
magister said

…the graphs are totally blank…


Same for my #075054 P3. Can you fix it?

#15

Bump for fix of my Powerplay performance charts please.


#16
bv1pacb said
magister said ...the graphs are totally blank...

Same for my #075054 P3. Can you fix it?


Hello bv1pacb! Your performance graphs should now be displaying. Thanks for letting us know about the issue. Have a great day!

#17

Thank you Kevin. Working now except for the Wattage display on the daily graph as per the screen shot. Watts do appear on the monthly.

PSAudio-Powerplay-Graph-1.JPG


#18

Daily Wattage graph is now showing today. Thanks again.


#19

Anyone know how to enable powerplay performance stats. I’ve had my P10 registered and connected for 2 days and still have no stats - it’s all blank.


#20

I just logged in. It is working fine.