P10 problems


#1

I have two problems with my P10.

  1. Both C1 and C2 sector is dead. There are no indications of anything failing, there is just no voltage present on those ‘green’ outlets.

  2. The E2 outlet is not part of the configurator on the latest firmware (?)

Except for this everything else is just fine.

I reckon the reset button in the rear is only pushed if the entire P10 fails to operate?

Any ideas?


#2

Did you get your problem solved? Perhaps, contact PS Audio Tech. The response time for me has been great for questions. Reinstall most current firmware .39. Possible sensor issue?


#3

Frode I hope your P10 will not need to go to service.

It seems to be pretty slow in the Europe in my own experience…

My P10 have been sent to service in September and till this day I don’t have it back (3 months…) - now the service is waiting for regenerator replacement part being sent from US…


#4

Frode,

Is your P10 problem solved?

Paul


#5

No I haven’t.

I was hoping for some specific ideas herein first. I did not buy the P10 through a local dealer.


#6

I assume you have unplugged and plugged it back in? Turned the non-function “green” outlets off and back on? The reset button seems to be for the breaker that should cut off all power but I would try pushing it anyway just in case (you probably have by now). I can’t think of anything that isn’t fairly obvious. Otherwise I would suggest contacting Alex to see if he has any ideas.


#7

Thx.

Tried all of this many times except for the main breaker reset.

The reset function is for a P10 that is dead (I presume). Mine is working.


#8

I suggested the reset under the “when all else fails, try anything” approach.