P5 issue - power on, screen on, but no power output

My P5 is unfortunately acting up. It’s getting power, the touch screen is working, all the receptacle s are green, everything I can tell looks fine…but none of the components are getting any power. Worked great last week, now nothing.

Fuse issue? Would that cut the power to the whole thing, or just the power output to the components?

Of course this happens on a Friday evening when the service department is closed for the weekend. SMH…

Any help of suggestions would be appreciated.


I assume you did a AC power reboot?

Yep, multiple times. Still no power output thru any receptacle.

Shoot - Sorry to hear this.

Have you tried any Firmware? Email me at tjt@psaudio.com for a Forceload version and let’s see if that solves it. Software can be a tricky beast.

Isn’t there a relay that connects power to the outlets? Sounds like that might be shot.

Actually - good point.

@kevin-r-torske Does the unit make any clicking when turned on or when a zone is turned on or off?

Yes, the unit does “click” during the power on sequence. No clicking when zone turned on or off.

Hmmm… All the zones have no click?

It’s weird they’d all go out at once, but also may be some circuit connecting to them. (It’s hard to tell from the schematics.) So - let’s hope there’s some firmware corruption, as odd as it sounds.

The green zone ON in the GUI doesn’t come ON because power has been detected at the outlets. It only comes ON because of switching logic in the software. This was discussed a long time ago.

Also, strange, is that since this issue started happening, if I reboot the P5, half the time it comes on in “European” mode, with the front screen showing european-styled recepticals.

Whacky. Never heard that one before.

No, no clicking from any of zones when screen buttons pushed.

This is kinda sounding more and more like firmware. Were you able to try that load I sent?

I’ll try installing the latest firmware after I get back from lunch (can’t be late meeting the misses).

I presume installing this firmware is the same method as installing it for the DirectStream DAC?

Haven’t received the email yet with the firmware attached.

Just got it. I’ll try to install after lunch and get back to you…

Ha! - No worries.

The procedure is exactly the same, except for the SD needs to be pins down.

Let me know!


Tried the new firmware. No change. :frowning:

Darn - sorry to hear that.

I’ll talk to a few engineers before we talk repair. Give me a couple hours and I’ll get back with you.


A loose ribbon cable between the IO board and the output/relay board would explain both the relays not working and the European mode.

That or possibly the I/O card. So if you want to look and see if that cable is seated there’s a chance that will take care of it, otherwise it probably needs to come in.

Let me know!