PCM Optical Input from LG OLED TV Not Working on DSD DAC


#1

Very strange issue. My Harman Kardon DVD player optical out works fine, and the optical output from my LG TV to my previous DACs also worked fine, including the DSJ. The input display shows green and correctly displays the bitrate of the PCM output from my TV, but there is no sound.

Any troubleshooting assistance would be appreciated. Have also tried swapping cables, no luck. Again, this is specific to my DSD DAC.

Here’s the config: Roku streaming Netflix into my TV, TV configured to play audio via built-in speakers AND PCM optical out. The sound also does not work when I set my TV’s digital/optical out to “Auto”. LG E55OLED I believe is the model of the TV.

OK, additional information: This appears only to be the case streaming Netflix or Amazon through the Roku (but again the PCM optical out is from the TV to the DAC) and not with broadcast TV, where the sound indeed works. Thing is, all TV inputs work fine with my other DACs (a Teac UD-503 and a MyTEK Brooklyn DAC+).

I have a friend with a similar issue which he is experiencing with two DACs including a PS Audio DL III (my old one, which worked fine on my TV) and a ESS 9039PRO based Chinese DAC.

This ever happened to anyone else?


#2

edit - what if you set tv to only do optical out ?

Also, silly question, are you sure you plugged the optical cable all the way in?


#3

In general the display of the DS and DS Jr will show identical sample rates, number of bits, etc. with identical inputs and if one plays a signal the other will, because the software and hardware to decode TOSLink (and S/PDIF, AES/EBU, I2S and even USB) are identical between the DS and the DS Jr (and FWIW nothing like any other PS Audio DAC or anything that uses a chip to receive TOSLink, etc.). That might help point in a particular direction (e.g. are you sure that only changing the DAC is the difference between working and not working?, same TOSLink cable, same outlets, same audio interconnects… (Tho I doubt that they could cause this.)

You might need to check that your source (and your TV) are set to stereo PCM outputs, not any other kind of encoding, e.g. DTS or multichannel PCM. (There’s (what I consider to be) a bug in the DS and DS Jr: they won’t accept a mono PCM input (tho very few devices output mono PCM.))

Also verify that all of your tests thru a TV have the same source sample rate, and that the DACs display that same sample rate. If not you may be comparing apples to oranges in that the TV is processing (probably downsampling, but perhaps other DSP like hall simulation or doing bass management …)

[Edit: Also if your hardware supports it you might try an RCA cable at least as a debugging step.]


#4

Also, is there a chance that you have multiple inputs connected to the DS DACs and that you were relying on automatic input select on the Jr selecting the active TOSLink input (which isn’t a feature of the DS)?


#5

Not sure if it is relevant but have you tried connecting all your video sources to the TV via HDMI alone, then using a single TOS link from the TV for all your sources?

I’ve been using my (old) TV as an HDMI switch in this fashion for several years and had no problems with sound output.


#6

Not sure if this helps but I have a USB from PC and Toslink from Sony to Jr. I have to select 4 or 6 I believe but I have to select them directly. No other feature such as “auto” works well , it causes problems. I have also at one point had to unplug cable from TV and re-plug in. This was a 1x though…


#7

This was the first thing I tried, and I’ll use this reply to explain how I got it to work. Indeed, I tried configuring the TV to use optical out ONLY and had no luck. Then I went through the cable switching routine.

What finally did work was restarting both units (TV and DAC) a few times, ensuring the TV was set to PCM (which of course I had already done, but made sure that it hadn’t reverted to “auto”) and eventually it just started working with the Roku.

Very strange issue, and it’s one that has been afflicting my friend for a few months to the point he has Samsung and LG both looking into it. I don’t even want to hazard a guess as to why this restarting regimen finally worked, but things are working now. Incidentally, the volume (even on bypass setting in my TV) using the PCM output TOSLink input to the DSD is much lower across the board than any other source, but whatever.

Edit: P.S. How could I forget to add that these are steps I still have to take about every third time I turn the TV and DAC on. So if I power both down, I sometimes have to engage in this little power cycling game for a few minutes until it “catches” and the DAC begins producing audible output. Again, literally nothing changes on the DSD display from when there isn’t sound to when there is sound.

Thanks for the help to all who answered.


#8

Yeah just for purposes of clarity and posterity to anyone else who may ever experience this issue, I indeed have all my video sources going into the TV via HDMI (to include the audio) and a single TOSLink optical out going to the DSD.


#9

(1) An hdmi deembedder would be a nice experiment inserted after Roku and before tv.

(2) Also an Spdif reclocker on the output of the TV. This one is more experimental.


#10

Yeah, good ideas.

Off topic - Did the moderators suddenly restrict or remove the “Edit” function for everybody or just me?


#11

Editing should be alive and well.

There is a quirk where the “What are you Spinning” thread does not allow edits. I suspect this has something to do with posting embedded images. I did my best trying to solve this some months back.

Once in a while the system will lock a post after the user has edited it. I do not have a good guess as to why.


#12

I’m certain the edit lock issue has to do with embedding images. It is not unique to the “What are you Spinning” thread. You have a couple minutes after embedding an image to complete any edits. After that you get a “system” message, if you remain logged in, and you’re forever after locked out of any edits.


#13

Thanks. Good information.