Power Plant Display Upside Down

I turned on the Power Plant 10 after a long time sitting idle and the display came out upside down (picture attached). Has anyone encountered this? Given the settings were all gone I’m assuming some kind of firmware corruption - I’ve looked through the site but am not sure which files are needed for an update. Can some kind soul help point those out?

Screenshot 2020-12-09 at 10.52.17 AM

The latest firmware is on the Download page, second row. Just re-load it and see if it straightens out. I assume you’ve already shut it down and unplugged it from the wall for a while and then turned it back on to see if it fixes itself. If so then just reload the current firmware.

Yikes. I’ve seen this once or twice before. The machine is confused. Start with a hard reboot using the rear panel power switch. If that doesn’t work, contact us for instructions on a screen reset.

Hi Paul, have tried the hard reboot, didn’t work. I’d appreciate if you could send the reset instructions.


This is a really easy fix. Power the unit off with the rear switch. Now hold down the logo button on the front while you flip the unit back on with the rear switch. This will initiate the screen calibration. Hit the corners 1, 2, 3, and 4 and the screen will flip right side up.


Hit the corners 1, 2, 3, and 4 and the screen will flip right side up.

Really now …Jamesh you are far too young to know about “hitting” an electronic
piece of equipment and pop it back into action… :grinning:


I thought that only worked with vacuum tube gear of yore…

1 Like

Thanks! the screen reset worked, screen is right way up now but after the firmware upgrade the touch panel is not working (eg pressing on SETUP does nothing). Could someone help confirm the exact firmware folder I should use?

You may want to run through the screen calibration process one more time. Perhaps as you were touching the different numbers during that process it registered a touch in an incorrect area causing the calibration to be off just a bit. If that doesn’t work just give us a call or email and we’ll take a further look into getting this corrected.

Thank you, I shall try that.