PowerPlant front display is static (not changing)

Hi I noticed that the front display on my PowerPlant P3 is static. It shows the incoming voltage as 226v currently and the load as 19 regardless how many devices I plug into it (the 19 changes to other numbers up to a max of 80 with every reboot).

Is there any advice to get the display working properly again? The device itself is working perfectly, it’s just the front display that is not changing with the load.

Things I have tried so far:

  1. Reboot the P3 (tried a few reboots/also unplugged the rear power cable)
  2. Pressed the blue PS Audio logo on the front panel
  3. Changed devices across different zones (rear socket zones)
  4. Tried to access the web interface - not accessible (blue LAN LED is on)
  5. Pressed all the buttons on the remote control
  6. Write this message to the forum here :slight_smile:

Don’t hook up Ethernet to the P3. The wifi interface has non-solvable issues. Don’t hookup Ethernet to any PS Audio Power Plant. That is the short answer.


Oh my word thank you. I unplugged the ethernet cable. Problem solved ! :smiley:

1 Like

Or somebody will tell you that your Ethernet cable doesn’t cost enough.

No, it’s a bug. An unfixable bug.

1 Like

Might have an Oppo part inside.