Problems with PWD & Bridge


#1

I’ve had my PWD since last February. I’m currently running Firmware 2.4.3 and Bridge Firmware 2.14b and have been using this combo since 2.4.3 came out. I’m also using JRiver 19. Just after Christmas I went to play a high res file and got nothing but static/fuzz from the speakers. Hitting the stop button didn’t stop the static/fuzz. I had to start playing a regular ripped CD file, which would play. The PWD had also stopped displaying the album cover and the front power would no longer turn off the PWD. I turned off the main power switch on the rear of the PWD and powered it back on. Usually the network connection is made right away but I was getting a no network connection message but eventually it connected after 2 or 3 minutes. Same problems. I then did a reset of the bridge. That did not fix the problem. I tried a couple more power off / on and still the problem remained. I rolled back to Firmware 2.4.1 and that did not fix the problem. Finally I reinstalled the Bridge firmware (2.14b) and that solved the problem, albeit temporarily.



2 days later and I had the same problem. Did another reinstall of the Bridge firmware and that solved the problem for about 9 days. Today I turn it on via the front button and I’m experiencing all the same problems again. As I’m reinstalling the Bridge firmware, I start writing this message with the intention of asking why I keep having to reinstall the Bridge firmware after everything has been running fine for many months. However, this time when I go to reinstall the Bridge firmware, I get to the point where (after the webpage shows the file has downloaded and flashed) the webpage says “Rebooting System” but nothing happens. I’ve let sit like that this for 20 minutes but I’m afraid it might be hung at this point. Not sure what I should do. Suggetions?


#2

After 40 minutes the PWD re-initialized but the webpage still showed Rebooting System. This time the problem is not solved. The PWD will not shut off when the front button is pushed, album covers aren’t displayed and now the high res files just emit a high pitch buzz. My ripped CD files play fine. Suggestions as to what I should do next?


#3

I would suggest loading an older firmware version such as 2.2.0, then reloading the firmware version of your choice. It sounds like the current firmware install has somehow gotten corrupted. After that, it may be necessary to do the same with the Bridge firmware.



Please report the results of said operations and we will try to provide further solutions as necessary.



J.P.


#4
After 40 minutes the PWD re-initialized but the webpage still showed Rebooting System

Make sure the web browser does not keep the web site in its cache (refresh).


#5

Thanks wingsounds and frode. After my original post, I thought of what you suggested and rolled back the bridge firmware to 2.13c; no change. I rolled back to firmware 2.2.0; no change. I then reloaded both 2.14b and 2.4.3; no change. Each time that I do a “hard|” turn off and on with the switch at the back or when it re-initializes after a change to the firmware or bridgeware, it takes quite a while for the PWD to re-connect to the network (e.g., 2 to 5 minutes) and sometime it doesn’t connect until I reboot my router. When everything is working properly, it connects almost immediately.



So, after several hours of “playing” with it last night, no resolution to the problems.


#6

Does the front power button still not work after reloading the PWD firmware? Does it play properly through any other inputs?



You might try Gordon’s favorite reset: disconnect the PWD from EVERYTHING for several hours. Remove power, interconnect and network cables when doing this. This allows all internal components to fully discharge (zero volts, give or take Straylight’s quantum effects :D) and does seem to have good effects in some strange cases such as yours.



If the front power button still does not work, even with older firmware then it is likely time to call PS Audio and possibly return the PWD for service.



J.P.


#7

The front power button does not work after reloading the PWD firmware.



I only use the PWD via the Bridge. I got rid of my Logitech Touch soon after getting the PWD and don’t have a separate transport, although I could dig out an old CD / DVD players and try it on the digital inputs, but I’m not sure what that would prove. The PWD and Bridge still work for regular files (i.e., not high resolution files) and I’ve been listening to it for a few hours today.



I’ve sent a detailed email to Support and will call them on Monday if I can get home from work earlier enough. I’m in Ontario so with the time difference, if I can get home by 6, hopefully I can reach someone in tech support before their work day is over.


#8

What happens if you select different sample rates instead of Native or NativeX? Does it play properly then or just make noise when upsampling to a higher rate?



J.P.


#9

I called Support this evening and Alex asked the same question. To my surprise, high res files worked on sample rates other than Native and NativeX; but no album info / picture on the front screen. When I gave him the answer, he figured it was a problem with the digital board and to send the PWD back. Hate having to send it back, but not much one can do. Hopefully it’s not gone too long.


#10

With your description I was afraid that it was a real problem, but we had to give it a go in case it could be corrected at home. I hope that it is not gone too long. PS Audio does seem to make good effort to get repairs turned around as quickly as possible.



J.P.


#11

It arrived in Boulder yesterday (Jan 24) after shipping it from Mississauga, Ontario. I’m sure they’ll spend all weekend working on it and will be shipping it back on Monday. :wink:


#12

A completely reasonable expectation. :slight_smile:



PSA is pretty quick however.


#13

It will have to thaw first. :smiley:


#14

It’s back! 1 month and 1 day. Sure can’t complain about their turn-around time. Apparently they replaced the digital board and the touch screen.



Everything seems to be working like it should and I even have a new FW version (2.44). Hopefully no more problems.



I forgot how good it sounds. It really is an amazing sounding DAC.


#15

Yet another happy customer :wink:


#16

I am a happy customer. While not thrilled with the DAC failing (or the first P5 I bought failing as well), it happens. On both occasions, their service was exemplary. Good/great products and service to match.